Showing results for 
Search instead for 
Did you mean: 

Systemlink client 20R1 and above don't work

Go to solution


We recently updated systemlink from 19.6 directly to 20R3.1 ( A stressfull day 😣). Everything went kind of well except for the client. Once the 20R3 client installed, the data stopped getting to the testmonitor but still worked for the 19.6 clients. The 20R3.1 client worked on my computer which is in another network, so i was wondering if there's a new communication port to open on our production network for the 20R3 client. I checked the documentation and all the port mentioned are opened in our end except for the datafinder since i am not using this module. I asked to open those port but am not expecting that would change anything. Can someone help me with this problem

0 Kudos
Message 1 of 4
Accepted by topic author sklod

SystemLink Client 2020 R1 and higher moved all client to server communication to HTTP when publishing data and uses the preferred hostname specified in the NI Web Server Configuration utility on the server when connecting.


I would recommend opening the NI Web Server Configuration utility on the server and verify that the preferred hostname listed is valid and can be used by the client.  I typically recommend opening a cmd prompt on the client and making sure you can ping the preferred hostname for the server. There is a drop-down that allows you to easily pick from different options that may work depending on your network configuration.


Screen Shot 2020-10-16 at 8.48.18 AM.png

Message 2 of 4

Thank you, that was it. I really apreciate your quick reaction to my post. Since SystemLink is a new tool, i get really overwhelmed by all the parameters and forgot this one.

0 Kudos
Message 3 of 4

Thank you Joshua for you help! It saved us 😊 

Message 4 of 4