SystemLink

cancel
Showing results for 
Search instead for 
Did you mean: 

SystemLink switch from HTTP to HTTPS

Hello,

 

We currently switched our SystemLink server from http to https.

Our test sequence is running great with TestStand and it's communicating with SystemLink without any problems.

When we want to use our LabVIEW user interface we're experiencing some problems, and test results are not recorded by SystemLink.

 

I saw this message with a basic UI from TestStand examples, what do we miss in the configuration?!

 

An exception occurred inside the call to .NET member 'BeginExecution':
NationalInstruments.SystemLink.Clients.Core.ApiException: An error occurred while sending the request. ---> System.Net.Http.HttpRequestException: Une erreur s'est produite lors de l'envoi de la demande. ---> System.Net.WebException: La demande a été abandonnée : Impossible de créer un canal sécurisé SSL/TLS.
à System.Net.HttpWebRequest.EndGetRequestStream(IAsyncResult asyncResult, TransportContext& context)
à System.Net.Http.HttpClientHandler.GetRequestStreamCallback(IAsyncResult ar)
--- Fin de la trace de la pile d'exception interne ---
à System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
à System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
à RestSharp.Portable.HttpClient.Impl.Http.DefaultHttpClient.<SendAsync>d__14.MoveNext()
--- Fin de la trace de la pile à partir de l'emplacement précédent au niveau duquel l'exception a été levée ---
à System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
à System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
à System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)
à RestSharp.Portable.RestClientBase.<ExecuteRequest>d__71.MoveNext()
--- Fin de la trace de la pile à partir de l'emplacement précédent au niveau duquel l'exception a été levée ---
à System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
à System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
à RestSharp.Portable.RestClientBase.<Execute>d__58.MoveNext()
--- Fin de la trace de la pile à partir de l'emplacement précédent au niveau duquel l'exception a été levée ---
à System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
à System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
à NationalInstruments.SystemLink.Clients.TestMonitor.Swagger.Client.ApiClient.CallApi(String path, Method method, List`1 queryParams, Object postBody, Dictionary`2 headerParams, Dictionary`2 formParams, Dictionary`2 fileParams, Dictionary`2 pathParams, String contentType)
--- Fin de la trace de la pile d'exception interne ---
à NationalInstruments.SystemLink.Clients.TestMonitor.Swagger.Client.ApiClient.CallApi(String path, Method method, List`1 queryParams, Object postBody, Dictionary`2 headerParams, Dictionary`2 formParams, Dictionary`2 fileParams, Dictionary`2 pathParams, String contentType)
à NationalInstruments.SystemLink.Clients.TestMonitor.Swagger.Api.ResultsApi.CreateResultsV2WithHttpInfo(CreateTestResultsRequest requestBody)
à NationalInstruments.SystemLink.Clients.TestMonitor.Swagger.Api.ResultsApi.CreateResultsV2(CreateTestResultsRequest requestBody)
à NationalInstruments.SystemLink.Clients.TestMonitor.TestDataManager.CreateResult(ResultData resultData)
à NationalInstruments.Skyline.TestMonitorClient.Api.TestMonitorHttpApi.CreateTestResult(ResultCreateRequest request, ResultResponse& createdResult)
à NationalInstruments.Skyline.TestMonitorClient.Api.WeaklyOrderedTestMonitorApi.CreateTestResult(ResultCreateRequest request, ResultResponse& result)
à NationalInstruments.Skyline.TestMonitorClient.Reporter.BeginExecution(String programFile, String loginName, Boolean& errorOccurred, Int32& errorCode, String& errorMessage) 

 

0 Kudos
Message 1 of 6
(1,059 Views)

Are you using a self-signed certificate or a certificate from a certificate authority? Are there any network proxies between the machine running TestStand and SystemLink?

Mark
NI App Software R&D
0 Kudos
Message 2 of 6
(1,008 Views)

Hello,

 

We're using a certificate from a certification authority.

There's a firewall between the assets and the server and we're able to ask for change on it. I (normally) opened what's ask by SystemLink setup.

0 Kudos
Message 3 of 6
(998 Views)

Hi HVW, 

 

Thank you for your response. There is definitely a lot of possible causes for this.

  • Is a firewall blocking port 443 or another ports https traffic is on (the port used for HTTPS can be changed in NI Web Server Configuration)? I suspect it is unlikely that 443 is blocked, but its worth checking.
  • Is there a proxy between your test system in the public internet? It's possible that traffic to the Certificate Authority is being blocked, which would prevent the certificate from being validated.
  • Is the certificate you installed into NI Web Server include the complete chain, terminating in a certificate authority? 
Mark
NI App Software R&D
0 Kudos
Message 4 of 6
(987 Views)

Hi Mark,

 

- port 443 is definitely opened, we can have access to the SystemLink server through https.

- the test systems are connected together inside a VLAN, and firewall rules are opened between the VLAN and the server. The VLAN (so the test systems) do not have access to the internet. The server has an access to internet, I guess through a proxy, but we can't modify it and we're not the owner of it.

- good question, I'm a newbie regarding certificates, I ordered a TCID one to switch between http and https. On our corporate network, there's no problem (regarding the https lock inside the navigator). the certification authority is given by our company

 

I did not think about having a look on the VLAN (technical network) for SystemLink webpage, if I follow you we might have problem also with the check of the certificate through the webpage?

 

we also saw this possible configuration on the server, could it be related somehow?

HVW_0-1615224526415.png

 

 

0 Kudos
Message 5 of 6
(960 Views)

we finally were able to make the test, it seems that the lock is also ok for SystemLink webpage through our VLAN.

0 Kudos
Message 6 of 6
(956 Views)