SystemLink

cancel
Showing results for 
Search instead for 
Did you mean: 

Set cRIO Programming Mode through SystemLink

Hi all,

 

I am trying to deploy an RT exe to an NI-9047 that uses both FPGA and Scan Interface (hybrid mode) onto a cRIO through SystemLink without the use of the LV dev environment.

 

I have built the executable, created a package, and deployed it successfully to the cRIO through SystemLink. The issue is when the software starts and attempts to open the FPGA VI reference, the error -61201 is thrown. The details for that error are as follows:

  • LabVIEW FPGA: The chassis is in Scan Interface programming mode. In order to run FPGA VIs, you must go to the chassis properties page, select FPGA programming mode, and deploy the settings.

Our current work around is to deploy the chassis through the LV dev environment before installing the package through SystemLink. The issue is also not seen if the rt exe is deployed through the LabVIEW development environment before installing the package through SystemLink (either running built exe as startup or connecting to cRIO and running startup vi).

 

I am looking for a solution that does not involve using the LV dev environment once the package has been built to deploy and run the RT exe without error.

0 Kudos
Message 1 of 6
(157 Views)

If you need to use a hybrid mode, I believe the recommendation is to use the NI System Configuration API in your application when it starts up to programmatically set the mode for the slot.  

 

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000kI1TSAU&l=en-US

0 Kudos
Message 2 of 6
(121 Views)

Thanks for the reply,

 

This is not an issue with the slots being configured incorrectly, I can confirm this through MAX where the programming mode of each slot can be reviewed and set, and they are all correct there.

 

It is the programming mode of the chassis which seems to be set wrong when deploying through SystemLink. I will have a look through the NI System Configuration API to see if there is anyway to set the mode for the whole chassis there.

0 Kudos
Message 3 of 6
(116 Views)

Given the options listed for the Hardware Property Node here: http://zone.ni.com/reference/en-XX/help/373107N-01/nisyscfg/property_node_hardware/ it does not appear that the chassis programming mode can be set through the NI System Configuration API, only the mode for the modules.

0 Kudos
Message 4 of 6
(113 Views)

You are correct, there doesn't seem to be a programmatic way to set the mode for the chassis.  If you need to use FPGA mode it seems that the recommendation is to uninstall Scan Engine and only use FPGA mode.  

0 Kudos
Message 5 of 6
(68 Views)
Highlighted

I saw this KB article that describes what you have said as a potential fix. In this case we are running in hybrid mode and need the scan engine software installed.

0 Kudos
Message 6 of 6
(63 Views)