SystemLink

cancel
Showing results for 
Search instead for 
Did you mean: 

Send Package to SystemLink Client

Solved!
Go to solution

Hello,

We are currently using SL 19.6 on a couple of computers. I made a package, add it to the package repository.

After that I am going tho the managed systems and I click on Software. I add the package to the feeds and I click on apply and...

 

System Link is trying to go the available tab, but nothing happens and I have some errors:

 

The request to update feeds failed with error code 504.

The request to update feeds timed out.

 

I also can see a notification on some computers (not all of them) in the System Client Tray App.

Basically I can never see the available software, it's always running until the timed out.

 

But nothing happened, any clue?!

0 Kudos
Message 1 of 13
(1,640 Views)

When it errors out if you expand the details section, which feeds is it failing to update?

0 Kudos
Message 2 of 13
(1,406 Views)

I have no details:

 

HVW_0-1579788647978.png

 

HVW_2-1579788711919.png

0 Kudos
Message 3 of 13
(1,398 Views)

Hi HVW,

 

Can you try to open a command prompt, go on the NI Package Manager repository (it should be C:\Program Files\National Instruments\NI Package Manager) and then run this command: "nipkg info-installed"?

It will check all the available packages for your computer, but it can be a long process. I have already solved a similar problem with this command.

 

Clement

0 Kudos
Message 4 of 13
(1,394 Views)

Hello, I did it on one of my client. The command runs ok and stop after a while.

I tried just after to go to the available tab in SystemLink and same behavior. 😞

0 Kudos
Message 5 of 13
(1,323 Views)

Do your clients have internet access and can they connect to the feeds on ni.com?  If they have ni.com access does it go through a proxy?

0 Kudos
Message 6 of 13
(1,269 Views)

Hello,

 

We do not have any internet access on the client. But I tried on my laptop and I have an internet access and it's not working.

But I guess you're right, there might be a communication problem.

I am currently having a look inside my technical network, to see if the following ports are opened:

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000kKHnSAM&l=fr-FR

 

0 Kudos
Message 7 of 13
(1,253 Views)

If your clients don't have internet access then make sure you remove any of the ni.com feeds since they will cause things to possibly timeout.  The ni.com feeds for the NI package manager updates are unfortunately locked, however you can import the following state (extract SLS file and import using the States view in Systems Manager) and then apply it to the target using SystemLink's Software view for the target to remove them as well.

 

 

0 Kudos
Message 8 of 13
(1,236 Views)

Hello JoshuaP, thank you for your help.

 

Ok I applied the state. 

 

HVW_0-1580290872190.png

 

What I am supposed to do after that? I still have the timeout on the Available tab.

Go to the Feeds tab of my client and click on remove for all the NI feeds? that won't delete the feeds from the client?

Something to do on the NI Package Manager on the client?

Sorry for questionning...

0 Kudos
Message 9 of 13
(1,219 Views)

If you go to the Feeds tab on the software dialog make sure there are no ni.com feeds, if you do not have internet access.  Then make sure you have added the feed you uploaded your package to the client and hit Apply.  Then check the Available tab.

 

This video walks you through it.

https://www.youtube.com/watch?v=Nsnil-JXSuk

0 Kudos
Message 10 of 13
(1,192 Views)