Showing results for 
Search instead for 
Did you mean: 

NI Salt-Minion Service could not be started

Go to solution

I installed both the SystemLink server and the client (both the latest versions) on the same computer (Win10), and the following problems occurred while connecting:

"The NI Salt-Minion Service could not be started."

Before the client successfully connected to the server, I tried to remove it from Systems Manager and reset the server. It appeared in the Pending approval list, but still could not connect after passing.The computer firewall is off.

I don't know how to find out what the problem is.

0 Kudos
Message 1 of 6

If both are installed on the same computer can you try setting the server to "localhost" in the SystemLink Client Configuration utility.  "localhost" is special in the fact that it should automatically connect and doesn't require approving it.  It also avoid potential firewall issues.

0 Kudos
Message 2 of 6

If the salt-minion service is crashing you may also want to look at the minion logs under C:\ProgramData\National Instruments\salt\var\log\salt to see if there are any exceptions.


What version of the server and client do you have installed?

0 Kudos
Message 3 of 6

Hi,JoshuaP, Thank you for reply.

No effect after setting the server to "localhost" in the SystemLink Client Configuration utility.



I find Minion logs, but I still don't know how to fix the problem.

 The version of the server and client I have installed is 2020 R2.


look forward to reply

0 Kudos
Message 4 of 6
Accepted by topic author 丁一

Looks like something corrupted one of your files.  I would recommend deleting C:\ProgramData\National Instruments\salt\conf\minion.d\_schedule.conf and then restarting the NI Salt-Minion service from the Windows service manager.


It is a cache file and should automatically be recreated after the service successfully starts up.

0 Kudos
Message 5 of 6

Thank you very much. We solved the problem with your help

0 Kudos
Message 6 of 6