SystemLink

cancel
Showing results for 
Search instead for 
Did you mean: 

Feed failed to update

Solved!
Go to solution
Highlighted

I created a new feed (first one on this server with latest EAR) and uploaded a package. I went to my Systems Manager, chose a system, went to SW, then feeds, and added the newly created feed. I get an warning message "One or more feed failed to update. Packages available from these feeds will not be shown". The feed is for x64 windows and the target is a PC. I tried deleting and recreating feed and adding it to system, no luck.

 

Ideas on warning?

0 Kudos
Message 1 of 10
(1,873 Views)
Highlighted

If you expand the details on the errror dialog, which feed failed to update?  Yours or the NI or nick danger ones?

0 Kudos
Message 2 of 10
(1,863 Views)
Highlighted

It failed the feed I added.

0 Kudos
Message 3 of 10
(1,860 Views)
Highlighted

One other thing to note, the server is on two networks. I don't see how this would affect the loading of the feed that resides on that server, but it's a possible piece to the puzzle. The target device is on the secondary network. 

0 Kudos
Message 4 of 10
(1,857 Views)
Highlighted
Solution
Accepted by topic author wrkcrw00

Problem solved. Thanks Josh P for suggesting what to look for (outside of this post). To complete the thread though, the issue I had was with the security certificate I generated to use https. I generated a self-signed cert using the NI Web Server Configuration tool. My original cert only included the DNS name of my server and NOT the IP I used on my secondary network. I regenerated and installed the cert with the the DNS name and secondary IP and problem solved.

 

On the NI Web Server, expand "Generate a new certificate" and make sure all domain names and IP's are represented there before generating the cert and installing it. 

 

image.png

Message 5 of 10
(1,832 Views)
Highlighted

I am trying to push a feed package in remote device(my rio)

but following error occur:

One or more feeds failed to update.
Packages available from these feeds will not be shown.

0 Kudos
Message 6 of 10
(934 Views)
Highlighted

Is "test" a valid feed on your SystemLink Server hosted from the Package Repository?  If you renamed or removed the feed you will need to remove it from the target and possibly re-add it.

0 Kudos
Message 7 of 10
(929 Views)
Highlighted

Thanks JoshuaP: how I know whether it is valid or not?

I have not renamed or delete it from package repositry

0 Kudos
Message 8 of 10
(659 Views)
Highlighted

kindly guide me where the certificate I have to install

0 Kudos
Message 9 of 10
(333 Views)
Highlighted

You may need to update your SystemLink Server to 2020 R1 or higher.  Previously, SL wasn't adding the certificate to the cert store on RT targets which wasn't a problem initially, but newer versions added a check which could cause issues.

 

The newer version of SL will automatically add the cert for the server to the target when it successfully connects and execute the appropriate commands.  You just need to ensure the cert on your SystemLink server includes the ip address (103.4.94.110) and/or hostname for your server that your target is using.  This can be done using the NI Web Server Configuration utility on your server.

0 Kudos
Message 10 of 10
(183 Views)