SystemLink

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot connect to DataFinder using Data Navigator

Solved!
Go to solution
Highlighted

Similar to this post but different error: https://forums.ni.com/t5/SystemLink/Cannot-connect-to-DataFinder-instance-using-Data-Navigator/m-p/3...

 

I've installed an evaluation of "TDM DataFinder Module User License" and using SystemLink 19.5, I am unable to connect using Data Navigator.

 

Error:

0 Kudos
Message 1 of 5
(110 Views)

Hi Tom,

 

I am not familiar with that particular error, but I can tell that it is coming from the ASAM-ODS layer that is required to interact with the DataFinder from the Data NAVIGATOR.  It is also possible to communicate directly to the same DataFinder without using this extra ASAM-ODS layer, using NI applications DIAdem or LabVIEW.  Do you happen to have either of those installed?  If not, would you be willing to install an evaluation version of DIAdem to test the DataFinder directly?

 

Did you check the checkbox in your DataFinder's configuration to "Allow access to DataFinder through web connections", found in the "Remote Access >> Web Access" section of its configuration?  Did you apply your own custom hierarchy in the "Remote Access >> DataFinder Hierarchy" section, or did you just take the default hierarchy?

 

Have you tried starting up the "NI SystemLink TDM Configuration" application/dialog and resetting the "Naming Service" or restart the services in the "Other >> Status" section of the dialog?  Either or both of these steps might clear up your issue.  Also rebooting the computer might help, if you haven't already tried that.

 

Brad Turpin

Senior Technical Support Engineer

National Instruments

0 Kudos
Message 2 of 5
(72 Views)
Highlighted

Hi Brad,

 

I installed an evaluation of DIAdem 2019 and tried to connect directly (used the export client configuration). The application hangs for several minutes then I receive "Error on opening the "DataFinder" type data source..."

 

DIAdem Error.JPG

 

  • Checkbox is checked:  "Allow access to DataFinder through web connections" 
  • Used the default settings for the "DataFinder Hierarchy"
  • Reset the "Naming Service" and restarted server and services

During this step I took a look at the services running on my server and noticed several NI services were stopped (it didn't allow me to start them either):

 

NI Services not starting.JPG

Restarted the machine several times and checked above settings with the same results. 

 

Some other info:

  • Using SystemLink 19.5 w/purchased license
  • Using TDM DataFinder Module User License (evaluation)
  • My server has an SQL instance running on it for another application (can this cause conflicts?)

All other SystemLink application seem to be running fine and are unaffected.

 

Thanks for your help.

0 Kudos
Message 3 of 5
(46 Views)
Highlighted

"NI PSP Service locator" needs to run to make DataFinder work.

 

  • Restart was already done. (Missing restart might block the service)
  • Did you disable windows fast boot like the installer requested?
  • Does this service start if you start it by hand?
0 Kudos
Message 4 of 5
(30 Views)
Highlighted
Solution
Accepted by tomfrausto

Hi AndreasK,

 

Thanks for the suggestions. You're suggestion to restart the NI PSP Service Locator manually, helped point me in the right direction and solve the problem!

 

I tried restarting the service manually and encountered the following error:

 

"The service did not start due to a logon failure". For some reason the default "NT SERVICE\lkClassAds" account does not have sufficient privileges to start the service on my Windows 2012 R2 Server:

 

  1. Followed these steps to start the service using a "Local System Account"
    1. https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000015CdnSAE&l=en-US
    2. It didn't work... so I tried the next step
  2. Added "NT SERVICE\lkClassAds" to the admin group on my server.
    1. This fixed it.

Looks like this:

 

added lkclassads to admin.JPG

Once I added the service account to the admin group, I was able to start all the services mentioned above. Restarted the machine and all services were running properly. I'm able to connect using "Data Navigation" and DIAdem.

 

Thanks for your help!

 

0 Kudos
Message 5 of 5
(22 Views)