SystemLink

cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot connect SystemLink Client to Server over the internet

Dear all, I created the SystemLink server and make the IP address of the server public over the internet by NAT method at the port 9091 (https://1.52.x.x:9091) I can access to the server from anywhere on the different networks. However, I can not connect the client to the server with the IP address 1.52.x.x . I did not see any requests for the approvement on the server. Please help me to solve this problem. I will really appreciate your helps.
0 Kudos
Message 1 of 9
(1,698 Views)

The clients also need to be able to connect to the server using ports 4505 and 4506.  These are the ports used by the Salt Server and Salt Minion (client), which is used for approving and managing the systems as well as transferring credentials to the client.

0 Kudos
Message 2 of 9
(1,660 Views)

So what should I do now? 
I also add the ports 4505 & 4506 to the exclusion in Firewall inbound rule.

And the SystemLink Client application and SystemLink Server application need to be at the same version, don't they?

0 Kudos
Message 3 of 9
(1,654 Views)

d4nvjpl0ng4n_0-1591331024822.png

For now the client can send the connection request to the server but it changes the status to "Not Approved" immediately. After that I go to the server and approve the request, but the client still be disconnected. 

I don't know why. 

0 Kudos
Message 4 of 9
(1,645 Views)

Seems you have some connection going on now. Your answer probably lies in the slat connection logs.

Regards,
André (CLA, CLED)
0 Kudos
Message 5 of 9
(1,639 Views)

Where should I find the connection logs? 

Do you know what is the reason for this problem?

0 Kudos
Message 6 of 9
(1,635 Views)

All I cound find was this KB: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000kGcSSAU&l=nl-NL

 

It provides the location of the salt logs for the server and client.

 

Have a look through and find the lines that indicates erroneous behavior.

 

As with all networking things there is a multitude of error sources.

Regards,
André (CLA, CLED)
0 Kudos
Message 7 of 9
(1,630 Views)

The SystemLink Server is backwards compatible with older clients, however you cannot connect a new client to an older server.

 

Also, you will need to add your public IP address to the RabbitMQ setting in the SystemLink Server Configuration Utility and you will need to add the public IP address in the NI Web Server Configuration utility as the preferred hostname and the SSL certificate if you are using HTTPS.

0 Kudos
Message 8 of 9
(1,611 Views)

I can connect the client to the server by changing setting of the router. The problem is due to the NAT port processing. Thank you all for your help

0 Kudos
Message 9 of 9
(1,561 Views)