SystemLink Forum

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to find System Link 19.0 Test Monitor G API

According to the system Link V19.0 manual there should be an official Skyline G (SystemLink nodes, or functions) for Test Monitor available for LabVIEW 2016 or later. After upgrading SystemLink Client to V19 can't find the vi's in (Skyline) Test Monitor vi's.

 

http://www.ni.com/documentation/en/systemlink/latest/api-reference/systemlink-api-reference/

 

Where can i find / install the official G - API Test Monitor vi's??

0 Kudos
Message 1 of 5
(2,485 Views)

It installs with the SystemLink 19.0 Client, which is available in NIPM. Note it only supports LV 2018 and higher because it leverages malleable VIs. 

0 Kudos
Message 2 of 5
(2,479 Views)

According to the manual it LabVIEW 2016 or later should support it (LabVIEW 2016 has also has malleable vi support). Updating system Link Client does not show the API vi's in the skyline menu.

0 Kudos
Message 3 of 5
(2,474 Views)

Malleable VI's were not fully supported in 2016 and there were additional features added to malleable VI's in 2018 that are required for the SystemLink Test Results API to properly function.

 

http://zone.ni.com/reference/en-XX/help/371361R-01/lvupgrade/labview_features/

 

While, we do support LabVIEW 2016 and later for Tags, Messages, and Files, the Test Result API is only supported in 2018 and higher.  

0 Kudos
Message 4 of 5
(2,463 Views)

Hi Joshua,

 

Thank you for your quick reply, clear explanation. We have to ask NI to update their manual  http://www.ni.com/documentation/en/systemlink/latest/api-reference/systemlink-api-reference/  which defines it is available in LabVIEW 2016 or later.

 

Thank you,

 

Coert Ansems

0 Kudos
Message 5 of 5
(2,458 Views)