Switch Hardware and Software

Showing results for 
Search instead for 
Did you mean: 

visa cannot currently access it error

Re: visa cannot currently access it error

The cable I used before was not null modem cable. Now it works. Thanks a lot!
Message 11 of 21

VISA error code 0xBFFF0072.

I am a project student and I'm very new to LabVIEW 8. My device is using a MSP430F169 microcontroller to run a program using a software, IAR Embedded Workbench IDE though RS232 cable (Connected to COM 1) and display the output using LabVIEW. I'm using the example given in LabVIEW (Basic Serial Write and Read.vi).


Error message when i click on Validate:

Could not open a VISA session to "ASRL1::INSTR".

VISA error code 0xBFFF0072.

The resource is valid, but VISA cannot currently access it.


Under Device Status:

VISA returned this device when finding resources, and MAX could use VISA to parse the resource name.  The resource is busy, so MAX could not succesfully open a VISA session to the device.


Does anyone know what is the problem? Is it the connection between VISA and my device? the Programming is not compatibale or Configuration of LabVIEW?

Please Help~ Thanks.

0 Kudos
Message 12 of 21

Re: VISA error code 0xBFFF0072.

Hi 8500,

It sounds like the serial port you are trying to configure is in use already.  I would make sure no other application is trying to access that port.

Also, please keep in mind that posting at the end of another discussion forum will not get as much attention as posting a new discussion forum.  In the future, you'll receive a more precise and expedient answer by posting topics such as this one in the LabVIEW or Instrument Control (GPIB, Serial, VISA, IVI) boards - http://forums.ni.com/ni/board?board.id=140

Best regards,

Chad Erickson
Switch Product Support Engineer


Message 13 of 21

Re: VISA error code 0xBFFF0072.

Oh Thanks alot Chad PSE, Thanks for the advise. Merry Christmas~ Smiley Very Happy



XiuHuan (8500)

Student of Nanyang Polytechnic


0 Kudos
Message 14 of 21

Re: visa cannot currently access it error

Hello AW#$,

I saw your forum, I am facing the same proble as you faced.

I want to know what exactly was the problem?

Is that bcoz of the null modem cable ?

0 Kudos
Message 15 of 21

Re: visa cannot currently access it error

I'm having similar issues and this has been duplicated on another machine with similar errors.  I have a device connect through USB, com4.  It shows up in Meaurement and Automation Explorer and validates correctly.  When tying pin 2 and 3 together, the loopback test works in hyperterminal, but not in MAE.  When sending *IDN?\n and setting the read back to 6, I get a BFFF003E error after trying to execute. I get the BFF error with the default settings as well.  I've gone through all the threads and Internet searches and cannot seem to find a solution, any help would be appreciated. I need to get the loopback working before I can make any progress...right?




0 Kudos
Message 16 of 21

Re: visa cannot currently access it error

I've been experimenting with the Count value in MAE on Basic IO Read.  I set it to 23 or 24 and I'm now getting a response from the device.  So, there is some progress.

0 Kudos
Message 17 of 21

Re: visa cannot currently access it error

I am able to get the device to respond correctly.  The device is from Sure Electronics and it's their dual axis magnetic sensor module with uArt.

So, in MAE, you need to set your baud rate correctly, plus on the write you need to use $sure ga\r\n  (there is a space between sure and ga but I did not use \s

The \r\n is required for the "enter key"  which is required for the sensor, ga is the command to return the degrees reading.

So, after many hours, I'm getting Angle=019deg.\r\n   I'm hoping I can now parse this out and get labview to display it as a compass.  Cheers....

0 Kudos
Message 18 of 21

Re: visa cannot currently access it error


I am also getting 'The resource is valid, but VISA cannot currently access it" error. I have Mac OS 10.6.8  which I booted on 32 bit kernel to be able to use stable 5.0 version of NI-VISA  instead of 64-bit  5.1.1 beta version. I am using serial to usb adapter to control some stepper motors.


When I run the  NI-VISA Configuration utility I can see my device USB::0x067B:: ..and I give it an alias. I then run USBTMC.vi and for the VISA resource name I enter the full resource name (or the alias) but it doesn't work. But when I try ASRL3::INSTR  I get this error.


Any ideas on what I'm doing wrong?


0 Kudos
Message 19 of 21

Re: visa cannot currently access it error

Hello guys! I am experience a similar issue, when trying to access my Newport ESP301 from NI-VISA Interactive Control tool. I use a straight-through RS232 cable (as specified for that device). I set the baud rate and all the other parameter on the Window´s Device Manager and on the NI Visa control too. The protocol is set on CTS/RTS and the termination si carriage return. everything seems to be set fine, but when I try to identify the device I get a Time Out error. Reading the status Byte will also give an error: " there is a conflict in the configurations". But was not able to find any conflicts so far. Anyone can help me?
0 Kudos
Message 20 of 21