Switch Hardware and Software

Showing results for 
Search instead for 
Did you mean: 

Using Switch Executive Trial

Go to solution

Hi Ppl,

I'm using LabVIEW 8.6 trial. When i installed switch executive through Drivers, i found Switch executive VI's are not there. But the installer shows the NI - SWITCH features to be installed. When i checked the vi.lib folder, SwitchExecutive folder was missing. And also there was no Switch Devices listed in Devices and Interfaces of MAX.


Should I activate LabVIEW to use Switch Executive ? what is the procedure for installation ?



0 Kudos
Message 1 of 7
Accepted by topic author lordsathish

Hi Lordsathish,


I believe NI Switch Executive 3.0 released before LabVIEW 8.6, so the default installation procedure would not place the NI Switch Executive VIs in the LabVIEW 8.6 folder.


To install NI Switch Executive 3.0 for use with the latest LabVIEW version, select the non-default option to install support for the latest version of LabVIEW during the NI Switch Executive installation.


In your case, you can modify the NI Switch Executive installation (from Add/Remove Programs) and select this option.


Hope this helps!  Let me know if you have further questions or it this does not solve your issue!


Chad Erickson

Switch Product Support Engineer


0 Kudos
Message 2 of 7

Hi Chad,

Thanks for your solution that really worked. I uninstalled SwitchExecutive and Reinstalled with the Install the entire feature in the local drive option selected.



0 Kudos
Message 3 of 7

Hi Chad,

Sorry, My poblem is not fixed yet. There were few SwitchExecutive VI's in instr.lib  I mistook them for vi.lib. i reinstalled the entire SwicthExecutive, but it still didnt work. Give me procedure to install it.


0 Kudos
Message 4 of 7



If you have earlier versions of labview, you can try installing Switch Executive and then copy the vi.lib part from previous version to 8.6.


I believe Switch Executive must be showing up in MAX in software section. Could you check on your side.



....../ '---_BOT ____________ ]
....// (..) ),----/....
0 Kudos
Message 5 of 7

Hi Vaibhav,

I tried this also. But MAX is also not showing the Switch devices. When tried to copy the VI's form another PC to mine, it was searching for nise.dll. So i couldn fix the problem.



0 Kudos
Message 6 of 7

Hi Lordsathish,


I apologize about the delay in getting back to you.  Do you have the NI-Switch driver installed?


NI-SWITCH 3.8 - Real-Time OS, Windows 2000/Vista x64/Vista x86/XP


You should still be able to see your NI switch modules in MAX, even if NI Switch Executive is not installed, as long as the NI-Switch driver is installed.


In reference to the NI Switch Executive installation, I've attached several screenshots that will hopefully assist you.

1. instr.bmp and vi.bmp show instr.lib and vi.lib before the installation.

2. default install directory.bmp shows C:\Program Files\National Instruments.  Change this if you're using a different directory.

3. default - latest version not selected.bmp shows the default configuration if LabVIEW 8.6 is installed.  Note that LabVIEW 8.6 is neither present nor selectable.  Once again I believe this is because NI Switch Executive released before LabVIEW 8.6.

4. default - latest version selected.bmp shows the configuration you should use to install NI Switch Executive for use with LabVIEW 8.6.  Be sure to verify the directory is C:\Program Files\National Instruments\LabVIEW 8.6\ or the appropriate directory on your system.

5. instr after.bmp and vi after.bmp show instr.lib and vi.lib after the installation.

6. Switch Executive in MAX.bmp and Switch Executive in LV.bmp show the NI Switch Executive environment and LV palette, respectively.


Hope this helps!


Chad Erickson

Switch Product Support Engineer


Message Edited by Chad PSE on 02-06-2009 02:52 PM
0 Kudos
Message 7 of 7