Switch Hardware and Software

cancel
Showing results for 
Search instead for 
Did you mean: 

PXIe-2569 not showing up in MAX and PXI fatal initialization error -26802

Good afternoon,

   we are having quite an issue here. A while ago we bought a pair of PXIe-2569 to be added to our system but due to our development program timing constraint we could not install them until 2 days ago. I downloaded the custom device provided by Stephen_B on the NI website, installed NI-SWITCH 16.0.0, deployed it to our RT workstation, fire everything up and, out of 2 cards MAX was only showing 1.

 

Our system is made of a single 6-cores workstation, two PCIe-8372 connected to 4 chassis, 2 chassis per card. The chassis are quite crowded, the PXIe-2569 were installed on Chassis 2 and Chassis 4. Only Chassis 4 showed the card on MAX.

 

I then thought, we got a faulty card. I swapped the cards, still MAX was showing just the card on Chassis 4. At that point I thought we had a faulty Slot (card were installed on Slot 9 of Chassis2 and Slot 10 of Chassis 4). As such I move the card in Slot 9 Chassis 2 to Slot 10 Chassis 2. Same issue. Card not showing up on Chassis 2. At this point I thought of a whole Chassis issue. I moved the Chassis 2 card from Chassis 2 to Chassis 1. At this point both cards were showing up on MAX. Everything pointed to the Chassis, so I tried a spare PXIe-4300 card on Chassis 2 Slot 9, and the card had no problem, it showed up nicely in MAX.

 

I then removed the PXIe-2569 from Chassi 4 Slot 10, removed the PXIe-2569 card from Chassis 1, removed the PXIe-4300 from Chassis 2 Slot 9 and reinstalled the PXIe-2569 in Chassis 2 Slot 9. Rebooted, at this point I got the PXI Fatal Initialization error with code  -26802.

 

This seems to be happening anytime I have any PXIe-2569 card in Chassis 2.

 

On top of everything I tried several clean install of the RT, just to be sure, with the same exact results.

 

At this point I am out of ideas other than not installing the PXIe-2569.

 

Our RT configuration is based on 2016 version of LVRT, Versistand 2016, DAQmx 16, NI SWITCH 16.

0 Kudos
Message 1 of 5
(1,440 Views)

Please create a MAX report of the system and attach it to this thread.

 

The error code you were posting indicates a timeout of the NI Device Loader. Can you please post an image of the console out showing what happens before the error occurs?

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 2 of 5
(1,370 Views)

I have already contacted support and I am in touch with an application engineer to solve his issue. Thanks for your interest.

0 Kudos
Message 3 of 5
(1,368 Views)

@Claudio_G wrote:

I have already contacted support and I am in touch with an application engineer to solve his issue. Thanks for your interest.


I know I'm digging up an old thread, but were you able to resolve this. I am having a similar issue with a PXIe-1073. My application will run smoothly then out of no where I will blue screen showing "bad pool header" and the event log shows "Fatal: PXI Initialization -26802 A timeout occurred".

0 Kudos
Message 4 of 5
(97 Views)
Highlighted

I actually did but this was a weird one. Adding the PXIe-2569 to my chassis 2 (we have a 4 chassis setup) caused issues, while adding it to chassis 3 did not cause issues. So i tried swapping the chassis connection on the back of my real-time workstation and renamed the chassis in MAX back to chassis 2 and 3, and it worked...

 

EDIT: went back to my post from 2 years ago and realized the problem was with chassis 2 and 3 was ok. The solution of swapping the two chassis at the back of the workstation still applies.

0 Kudos
Message 5 of 5
(94 Views)