From Friday, April 19th (11:00 PM CDT) through Saturday, April 20th (2:00 PM CDT), 2024, ni.com will undergo system upgrades that may result in temporary service interruption.

We appreciate your patience as we improve our online experience.

Switch Hardware and Software

cancel
Showing results for 
Search instead for 
Did you mean: 

NI PXI-2503 - Access via Matlab causes crash

Hello everybody,

 

I'm a little unsure whether this is the right board. Please move it if necessary 😉

We bought a PXIe-1083 chassis (Thunderbolt 3) with the following cards:

  • PXIe-6356 (multifunction IO, BNC-2110 connection block)
  • PXI-2503 matrix (TB-2605 connector block)
  • PXIe-4610 power amp

The lab PC has following configuration:

  • Asus B550 Pro Creator
  • AMD Ryzen 9 5900X processor
  • 64GB RAM
  • Windwos 10 22H2 Enterprise, OS build 19045.4123, Windows Feature Experience Pack 1000.19054.1000.0

I have installed the following additional software to get the PXI-System to run:

  • ni-pxiplatformservices_24.0_online
  • ni-daqmx_24.0_online
  • ni-icp_24.0_online
  • IviNetSharedComponents_200 (not from NI)
  • IviSharedComponents_300 (not from NI)


I then installed the following additional support packages in Matlab:

  • Instrument Control Toolbox Support Package for National Instruments NI-SWITCH Hardware
  • Data Acquisition Toolbox Support Package for National Instruments NI-DAQmx Devices
  • Instrument Control Toolbox Support Package for IVI and VXIplug&play Drivers


Then I tried out sample code in Matlab to test the function of the modules.

  • PXIe-6356 via daq works.
  • PXI-2503 causes Maltlab to crash when I try to access the hardware.
  • I have not yet tried PXIe-4610 as I did not find any example code for activating the channels.

Relevant Matlab sample code that leads to crash:

configStore = iviconfigurationstore;
add(configStore, 'HardwareAsset', 'mySwitchAsset', 'PXI1Slot3');
add(configStore, 'DriverSession', 'mySwitchSession', 'niSwitch', 'mySwitchAsset');
add(configStore, 'LogicalName', 'mySwitch', 'mySwitchSession');
commit(configStore);
dev = ividev("IviSwtch","mySwitch","IDQuery",true,"ResetDevice",true);

-> The last line leads to a crash. This is probably where the hardware access should take place.


I described the problem with the PXI-2503 to Matlab support.
They told me to create a virtual hardware via NI Hardware Configuration Utility and try accessing it to isolate the bug.

My problem: I cannot start the NI Hardware Configuration Utility. After starting it from the start menu, the green splash screen appears.
In the bottom line you can see that something is loading. Then the splash screen disappears and nothing happens.

NI MAX works, you can also see and configure the hardware. However, no virtual hardware can be created.


I then looked in the Windows Event Viewer. I found at least one relevant entry there:

 

Error 07.03.2024 11:41:36 .NET Runtime 1023 None

Application: NIHardwareConfig.exe
CoreCLR Version: 6.0.2724.6912
.NET Version: 6.0.27
Description: The process was terminated due to an internal error in the .NET Runtime at IP 00007FFCE8D93C89 (00007FFCE8BC0000) with exit code c0000005.

 

Error 07.03.2024 11:41:37 Application Error 1000 (100)

Faulting application name: NIHardwareConfig.exe, version: 9.11.0.49352, time stamp: 0x6531c3c8
Faulting module name: coreclr.dll, version: 6.0.2724.6912, time stamp: 0x65ab2ae9
Exception code: 0xc0000005
Fault offset: 0x00000000001d3c89
Faulting process ID: 0x3270
Faulting application start time: 0x01da707c00564828
Faulting application path: C:\Program Files\National Instruments\NI Hardware Configuration\NIHardwareConfig.exe
Faulting module path: C:\Program Files\dotnet\shared\Microsoft.NETCore.App\6.0.27\coreclr.dll
Report ID: b6be1e27-a6d1-4740-a74b-263bb58fdb74
Faulting package full name:
Faulting package-relative application ID:

 

Information 07.03.2024 11:41:42 Windows Error Reporting 1001 None

Fault bucket 1949835692410142232, type 4
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: NIHardwareConfig.exe
P2: 9.11.0.49352
P3: 6531c3c8
P4: coreclr.dll
P5: 6.0.2724.6912
P6: 65ab2ae9
P7: c0000005
P8: 00000000001d3c89
P9:
P10:

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER213.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER1166.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER1177.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER1184.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER11B4.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_NIHardwareConfig_22846ebbbe76bb36f619744de142e4a9de3aac_be6b6a31_ae85a062-4f54-4cef-8c3e-065bebc9e0d6

Analysis symbol:
Rechecking for solution: 0
Report Id: b6be1e27-a6d1-4740-a74b-263bb58fdb74
Report Status: 268435456
Hashed bucket: 60c9dcff47db421efb0f353b487bfe18
Cab Guid: 0


Uninstalling the NI software and reinstalling it did not bring any change.
On another, freshly installed system (Windows 10 22H2 on a Fujitsu U749 notebook) everything works perfectly.

What could be the cause here?


Best regards

Mario

0 Kudos
Message 1 of 2
(171 Views)

A short update: I have identified a connection with Sophos Intercept X Endpoint. A message is not displayed in Endpoint - that would have been easy 😉

0 Kudos
Message 2 of 2
(144 Views)