Switch Hardware and Software

Showing results for 
Search instead for 
Did you mean: 

Example Switch Executive VI hangs



I'm trying to create a list of connected relays using Switch Executive VIs and been looking at some of the examples. In one of the two libraries, is a VI called 'Getting Started' so I had a go at running that to see how it worked, using the default virtual device name & connection specification. However, I've found the VI just seems to hang and when I try to close it, a message pops up about Resetting the VI, which doesn't disappear & I can't close. I have to quit Labview from the task manager to get round it.


Trying this again, with execution highlighted on the block diagram & a probe on the 'session out' from the Open VI that's called up, it shows the session value is zero but the error path reports OK.


If I change the virtual device to one I created in Switch Exec & update the connection spec, the session value is now non-zero but I get error -29003 when executing the Connect VI, which states "This session is not a valid NI Switch Executive virtual device session" so I'm not sure where I'm going wrong. That said, I'm able to use my virtual device name in a TestStand IVI switch step without a problem.


Since I'm using a mixture of software versions (Labview 2017, Switch Exec 2015 & TestStand 2014), I wondered if it's a compatability issue that's causing this?


Appreciate any advice.

0 Kudos
Message 1 of 3

Hi Bruce,


This error can happen for a couple reason. But it does seem like it is an incompatibility issue for your case. Looking at the Switch Executive 2015 readme, it is only compatible for LabVIEW 2012-2015.


I have also seen this error when you are trying to use a version of Switch Executive with an incompatible Windows version. Such as using Switch Executive 2015 on a Windows 10 computer. Switch Executive 2017 was the first version to start supporting Windows 10.

0 Kudos
Message 2 of 3

Hi Sherlockholm


Thanks for your reply. I'd forgotten to mention I'd just started using a Windows 10 PC. I've now upgraded my Switch Executive to 2019 (will be doing the same with TestStand), and problem solved.


Thanks & regards


0 Kudos
Message 3 of 3