Switch Hardware and Software

cancel
Showing results for 
Search instead for 
Did you mean: 

Change in voltage on one channel affects voltage in others

Hello,

    I am using PXI 1042q chasis with 8106 microcontroller. I am using PXI switch 2532 with TB 2641 and SCB264x breakout box. I have a question regarding the switch. When I change the voltage on one channel (I mean on one connection) I see glitches on other connected channels. I have attached the block diagram of my setup. Basically I am setting all the channels at some predefined voltage (lets say 500 mv) then I am changing one of the channels to ( 0 volts) as soon as I do this I see glitch on other channels. Similarly when I get back that channel to 500 mv I again see a glitch. I do not see glitches while switching, but I am seeing that while changing voltage, Which ruins the whole purpose of using switch network. I am using the anemometer to set up voltage on the sensors. Anemometer also has ac output channel which outputs the ac voltage which I am observing to look for glitches. I have followed the guidelines provided by chad regarding signal and ground wire connections. I am not sure where I made a mistake. Any suggestions in this regard would be helpful.

 

Thanks,

kartik

0 Kudos
Message 1 of 2
(6,021 Views)

Hello Kartik,

 

Can you quantify the glitch you are seeing, with a screenshot? Also, can you provide a screenshot of your matrix setup, I believe it could be an issue with some of the channels sharing routing lines.

 

Regards,

Glenn

Applications Engineer

National Instruments

 


Regards,
Glenn
0 Kudos
Message 2 of 2
(5,989 Views)