Smartphones, Tablets, and Mobile Devices Discussions

Showing results for 
Search instead for 
Did you mean: 

Data Dashboard viewing cRIO controller data

I am wondering if there have been any relatively recent changes in how the Data Dashboard app can communicate with cRIO data points?


We previously used the cRIO-9074 chassis in a control application, with the cRIO hosting the shared variable engine. With that controller, I could simply add a basic wireless access point to our control network, then access the cRIO by IP address and see any number of items through the Data Dashboard app on an Android phone (also tested on a Kindle Fire). The primary item for monitoring was actually an analog input channel (on an NI-9203 module) to see what the current sensor reading was in real time, to allow for proper positioning when setting up. This always worked flawlessly, didn't need any unique setup or configuration.


We now use the cRIO-9067 in our product, and I recently tried adding an access point to view the same analog input on the new controller configuration. I could see the controller by IP address. I could see the data tree and select the analog channel I wanted to monitor through Data Dashboard. But when I tried to run the dashboard, nothing would happen and the app essentially locked up. I tried this process with my Galaxy S7, with the Kindle Fire (both using Data Dashboard apps that had been loaded and proven to connect to previous systems). I then tried uninstalling and reinstalling the Data Dashboard app on both, but had the same strange behavior - no data, app just seemed to stop working.


I know with the 9067 unit, and the move to the Linux kernel in the processor, quite a few little things changed as far as security and connections. Did this also affect the Data Dashboard connectivity? And, if so, how would I unlock whatever the blockage is so that I can provide the data access to our customer that was promised to them, based on how the system should be communicating, and how previous versions had behaved? Is there some other potential stumbling point that I'm missing for directly connecting to a cRIO internal data point now?

0 Kudos
Message 1 of 1