Signal Generators

cancel
Showing results for 
Search instead for 
Did you mean: 

vi fails to load on remote host

I am trying to run a vi on a remote RT pxi chassis from teststand. I have two vi's the first is very simple and runs on the RT remote host fine. The second is calling niFgen sub vi's which will not run. I get the error "failed to load vi on remote host. The vi is not executable" and I get an error -17600. However if I run this vi from labview targeting the RT system it runs fine. Also if I run the vi from Labview and then without unloading it I run my sequence this also works. Any ideas anyone?

Nick
0 Kudos
Message 1 of 4
(6,200 Views)
Try this: mass compile or delete the fuzzy logic toolkit LLB, located in
Program Files\National Instruments\LabVIEW 7.1\vi.lib\addons\control\fuzzy\fuzzy logic.llb. The fuzzy logic toolkit contains an old version of Merge Errors.vi, which can conflict with some NI-FGEN VIs that use Merge Errors.vi.

Drew Creel
Software Engineer - Signal Generators
National Instruments
Drew Creel
NI Software Group Manager
RF and Signal Generators
0 Kudos
Message 2 of 4
(6,200 Views)
Hi Drew,

Thanx for the prompt reply, unfortunately I have already tried this (god bless the support portal). Could this old vi be found in multiple locations? Any help greatly appreciated.

Nick
0 Kudos
Message 3 of 4
(6,200 Views)
Hi Nick,

Here are a couple more things to try:

1) Open LabVIEW and go to Tools->Find VIs on Disk. Search for the "Merge Errors.vi". If you find any instances of the VI that are not in LabVIEW 7.1\vi.lib\Utility\error.llb, remove them.

2) Make sure the TestStand LabVIEW support files are mass compiled for LabVIEW 7.1 (by default they are compiled for LabVIEW 7.0). These files are located in Program Files\National Instruments\TestStand\AdapterSupport\Labview\LoadTarget.llb.

3) In LabVIEW, switch your execution target to your RT target and go to Tools->RT Target: Options. Under VI Server:Configuration, make sure TCP/IP, Allow VI Calls, Allow VI methods and properties, and Allow application methods and properties are a
ll checked and that the Port is 3363. Under VI Server:TCP/IP Access, make sure your computer (not the RT target) is in the TCP/IP access list. You can just add "*" to test it out. The defaults for the other option categories should work.

Hope this helps,

Drew Creel
Software Engineer - Signal Generators
National Instruments
Drew Creel
NI Software Group Manager
RF and Signal Generators
0 Kudos
Message 4 of 4
(6,200 Views)