Signal Generators

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Agilent 33250a interfacing

Highlighted
We are trying to interface an Agilent 33250a to be controlled via LabView. Where can we find the right colelction of settings?
0 Kudos
Message 1 of 8
(8,151 Views)
bugsmashers,

You can find a LabVIEW Plug and Play instrument driver for this instrument here:

Download ag33xxx Driver

Let me know if you need additional help with this but this instrument driver should provide you with everything you need in LabVIEW.

Craig H.
0 Kudos
Message 2 of 8
(8,139 Views)

Hello Craig,

I have a problem related to the use of Agilent 33250A drivers. The program i wrote for control 33250A  is working in XP properly using GPIB (green led acquired from the GPIB port) connection. But when i use this program in Windows 7 (laptop), i encountered connection problem even i see the green led on the GPIB port device.

 

How can i run my VI in Win7 laptop?

 

P.S. Connections are the same.

 

 

0 Kudos
Message 3 of 8
(5,986 Views)

Is there anyone to help me to solve this problem ?

0 Kudos
Message 4 of 8
(5,962 Views)

What do you mean by 'connection problem'? What is the exact error code/message do you get? Is the error generated in MAX or from just your program? What version of OS (32/64 bit)? What version of NI-488.2? What verison of NI-VISA? You need to provide these sort of details to have any chance of getting your problem solved.

 

Also, hijacking an old and unrelated thread is not the best way to ask a question.

0 Kudos
Message 5 of 8
(5,952 Views)

Hello Dennis,

I am a new user at this forum and usually solve my problems in Labview by myself more than one year. i was in a hurry and could not find the solution last time, from that reason i forgot to attach some VI files in the last message (My mistake). When i google, i found this section or thread, from that reason i wrote my problems here. Also, i didnot  understand "hijacking an old and unrelated thread" meaning.

 

I downloaded drivers using Labview (Getting started window > Tools > Find Instrument Drivers) from NI certified drivers and installed them. Also, i downloaded Agilent IO libraries suite 15.5 to provide connection between GPIB and computer (15.0 did not worked in Win7 which was supplied with 33250A and 15.5 is worked). After i plugged the GPIB/usb connection to computer, i see that GPIB is recognized and green led light is observed. I reached the device using drivers and set the parameters properly.

 

I recognized (after previous message sent to this forum) that win7 updated itself and from that reason, somehow, i see the connection between GPIB port and computer, but i can not initalize  the device or set the parameters (frequency, amplitude, etc ) using drivers downloded from the NI website. I reinstall the drivers but it didn't worked.

 

Win7 update causes this problem, how can i set parameters of 33250A using drivers again?

 

Thank you.

 

AC Function generator: 33250A Agilent

Labview version: Labview 8.0

OS system: Windows 7

Connection: 82357 B  USB/GPIB interface USB 2.0 connection

 

Message 6 of 8
(5,943 Views)
0 Kudos
Message 7 of 8
(5,939 Views)

Your LabVIEW code works fine on windows 10. I have used Agilent 82357A USB/GPIB Interface Converter to control Agilent 33250A Function Generator, through your LabVIEW Code. Could you please also share some comprehensive code which also captures wave-forms from from function generator and displays on graphs in Labview at run-time?

0 Kudos
Message 8 of 8
(873 Views)