Signal Conditioning

Showing results for 
Search instead for 
Did you mean: 

Why does access my SCXI-1122 consume 100% of system resources?

When acquiring data from the SCXI Chassis 1122 modules, using either MAX or LabVIEW example VIs, the computer requires 100% of the processing power as indicated by the Task Manager (little more than 5 Mb memory is utilized from the 64 Mb available). When the system begins sampling, the system does not crash, rather it bogs down; multiple seconds between clicking something and any response. There is no observable difference between sampling one channel and multiple channels. Sampling all forty -(40) thermocouples in the SCXI 1102 modules requires less than 7% of the system resources, according to the Task Manager. The 1122 modules contain K-type thermocouples, 4-20 mA, 0-5 VDC, and 0-15 mV signals
To isolate the problem, all modules were removed except one 1122. After reconfiguring the software, the problem persisted, regardless of using MAX or sample VIs. Fearing that corrupt signals were causing the problem, a spare terminal block with a single K-type thermocouple replaced the existing terminal block; the problem remained. Switching the module with a recently calibrated (9-12-01) 1122 did nothing to effect the problem.

System Information:
Win NT (ver 4 with service pack 5)
Pentium III 733 MHz (Dell)
LabVIEW 5.1
SCXI Chassis 1001
2 - SCXI 1122 modules with 1322 terminal blocks
2 - SCXI 1102 modules with 1303 terminal blocks
1 - SCXI 1160 module with 1324 terminal block
1 - SCXI 1124 module with 1325 terminal block
0 Kudos
Message 1 of 3

Are you using the same program when comparing acquisition of the SCXI-1122 with other modules? It sounds like the program is using interrupt based transfers when working with the SCXI-1122, and DMA based transfers with the others. If for nothing else than debuggin purposes, you can use the Set DAQ Device Info VI to set the transfer mode in one of the example programs.

Is the data from the SCXI-1122 modules valid? Perhaps that slot is for some reason bad? Could you try the module in one of the slots that worked with the other modules?

It is almost always worth a shot at using the latest NI-DAQ driver. You can get the latest one at Which version of NI-DAQ are you using now?


John N
Applications Engineer
National Inst
0 Kudos
Message 2 of 3
John N-
Your points are quite valid. The system has 2 SCXI-1122 modules recently returned from NI calibration and a brand new spare SCXI-11232 module. Every conceivable combination of terminal blocks, modules, and slots were tried, yet the system consumption remains at 100%. To eliminate the programming issures, I have been using MAX to directly read the data. MAX displays the proper reading as compared to a Fluke DMM. This morning the newest NI-DAQ driver (6.9.2 was loaded; with no noticable effect either positive or negative. Your suggestion to change the transfer mode shall be tried.

Thanks for your suggestions!

Ian J
0 Kudos
Message 3 of 3