Signal Conditioning

cancel
Showing results for 
Search instead for 
Did you mean: 

Full-Bridge Strain Vs. Custom Voltage with Ex: outputs opposite polarities of eachother (SCXI 1314)

Highlighted

Please see my Sig for current hardware specs.

 

I have a manufactured load cell that I'm plugging into an SCXI-1314 wired for full bridge. When I condition and calibrate the load cell as a Full-Bridge Strain channel (shunt cal) my signal output is POSITIVE in compression.

If I take the same load cell plugged into the same channel in the 1314 and select Custom Voltage with Excitation and give it a mV/V slope curve in the Custom Scale the signal output is NEGATIVE in compression.

 

Why is this? I fear I'm overlooking something very rudementary.

Other than the polarities  being opposite of eachother the signals appear just fine.

SCXI- 1000 Chassis w/ 1346 adapter
PCI 6281 DAQ card
SCXI- 1520 Bridge Board w/ 1314 Terminal Block (x2)
SCXI- 1180 Feedthrough Panel w/ 1302 Block
Signal Express 2014.
Win7 Enterprise
0 Kudos
Message 1 of 4
(4,350 Views)
Highlighted

Here's a drawing of our wiring/cabling convention for load cell/scxi interface.

SCXI- 1000 Chassis w/ 1346 adapter
PCI 6281 DAQ card
SCXI- 1520 Bridge Board w/ 1314 Terminal Block (x2)
SCXI- 1180 Feedthrough Panel w/ 1302 Block
Signal Express 2014.
Win7 Enterprise
0 Kudos
Message 2 of 4
(4,347 Views)
Highlighted

Hi OKors,

 

The strain scaling formulas are listed in chapter 4 of the SCXI-1520 User Manual and Specifications. They all multiply the result by a negative number, so there is an inverse relationship between voltage ratio (as returned by a Custom Voltage with Excitation channel) and strain. When you use a custom scale with a positive slope, the voltage ratio no longer gets inverted. You can use a negative slope in the custom scale if you want.

 

Brad

---
Brad Keryan
NI R&D
0 Kudos
Message 3 of 4
(4,333 Views)
Highlighted

Remembering to invert the slope of a custom scale isn't so hard to do, but for the unsuspecting user couldn't that could be a concern? 

 

I know it took me a day of troubleshooting and a post in the forums before I figured out why my data didn't make any sense.

 

SCXI- 1000 Chassis w/ 1346 adapter
PCI 6281 DAQ card
SCXI- 1520 Bridge Board w/ 1314 Terminal Block (x2)
SCXI- 1180 Feedthrough Panel w/ 1302 Block
Signal Express 2014.
Win7 Enterprise
0 Kudos
Message 4 of 4
(4,321 Views)