Signal Conditioning

cancel
Showing results for 
Search instead for 
Did you mean: 

Differential Inputs/2 mV Noise,

Helo all,
I was having some trouble with my measurement system, and I was wondering whether I could get some help on it:
My measurement signal goes into the NI board as a differential input. So, two inputs, a positive into AI0 and a negative into AI8. My probe signal first goes into an a hardware filter/amplifier and from there into the NI board. I am getting a noise of 2 mV, irrespective of whether there is a signal present or not. The only way to get rid of it is to short the differential inputs with a short wire, and then I still get 400 uV or so.
I read quite a few NI documents, including the manual. I cannot say I fully understand the manuals to be honest. However, I have the suspicion that I have to do some hardware config!
I cannot fgure out where the noise is coming from, and it is has quite a large amplitude! The noise is not coming from the filter either, because it is the same when the filter is turned on or off. 
Do you have any ideas I can try? Thanks a lot for your time.
Kind Regards
0 Kudos
Message 1 of 14
(5,359 Views)

Please help us to help you.  Give more detailed information.

 

What DAQ board are your using? How do you connect to it?  What is the bandwidth of your signal?  What are the filter and gain settings? Is the hardware filter/amplifier commercial equipment or something you made?  If commercial, what manufacturer and model?  What is your sampling rate?

 

Please post a VI which captures some of your noise saved as default values so we can see it.

 

Lynn

0 Kudos
Message 2 of 14
(5,355 Views)

What DAQ board are your using?


I am using a NI PXIe-6361 board.

How do you connect to it? 

With a NI SCB-68.


What is the bandwidth of your signal?
It ranges from roughly DC to 3 MHz.

What are the filter and gain settings? Is the hardware filter/amplifier commercial equipment or something you made?  If commercial, what manufacturer and model?

 For now I have completely bypassed the filter, and I am still getting the same amount of noise as before. It is a commercial Krohn-Hite 3988 filter. I had it set on 10 dB input gain; I used a Butterworth filter with a high pass frequency of 20 kHz.



What is your sampling rate?

2 MS/s.

 

 

I have attached two files, a .csv file containing the noise signal in the time domain sampled at 2MS/s, and a plotted version of it in .jpg format.

 

My suspicion is that I am picking up some RF signals, having observed that the amplitude of the signal seems to be modulated over time.

 

Kind Regards

Download All
0 Kudos
Message 3 of 14
(5,340 Views)

In the SCB - 68 manual it mentions that I will need to somehow configure the channel to DIFF input mode. Then it mentions connecting a resistor between the channel - terminal and GND. Is that all I need to do?

0 Kudos
Message 4 of 14
(5,328 Views)

When looking for problems like this I like to plot the data.  The mind is very good at recognizing patterns.

 

Your plot clearly shows a periodic pattern.  Next I calculated the FFT and found a spectrum with the strongest peak at about 3200 Hz and other peaks at 400 Hz intervals.  The time domain plot looks like a signal amplitude modulated at about 400 Hz. When I zoom in I see higher frequency patterns which are more complex.  When I expand the time domain plot to see individual data points, it is clear that some aliasing is occurring.  The kinds of jumps which occur between adjacent points is not consistent with a signal which meets the Nyquist criterion.

 

Of course your answers to my questions clearly indicate that you have an alias problem.  Bandwidth = 3 MHz, sampling rate = 2 MS/s.  For a 3 MHz signal the Nyquist criterion requires that you sample at a rate greater than 6 MS/s.

 

Your choices are 1. get a faster DAQ board, or 2. insert an anti-alias filter with a cutoff below 1 MHz before the device you have now.

 

You could also be picking up RF, but the aliasing must be addressed first.

 

Lynn

0 Kudos
Message 5 of 14
(5,327 Views)

Posts crossed.

 

For differential inputs you may need resistors to ground (or AI Common) from each of the inputs.

 

Lynn

0 Kudos
Message 6 of 14
(5,326 Views)

I don't know if you've read through this one or not, but this is one of our best articles about the different wiring configurations we recommend to deal with noise: http://zone.ni.com/devzone/cda/tut/p/id/3344

 

Whether you need the resistors or not depends on what type of source you are measuring. If you don't have a common ground between your measurement device and the DAQ device (floating source) you'll probably need them on each leg of the differential setup. (as mentioned in the article) 

 

 

Applications Engineer
National Instruments
CLD Certified
0 Kudos
Message 7 of 14
(5,321 Views)

Thanks for your time and your answer.

 

 

I am looking at only DC - 1MHz of my signal, since that meets the Nyquist criterion in my case.

 

What you looked at is the noise I am getting. Noise can go up to MHz as far as I know. Aliasing of the noise is not my worry.

 

 

I suspect it is my shielding, though, and also the grounding resistors. Would I need to solder them?

 

 

Kind Regards

0 Kudos
Message 8 of 14
(5,320 Views)

If you are only interested in signal components up to 1 MHz, you really should put a 1 MHz anti-alias filter in the system.

 

All of the noise in the 3 MHz bandwidth ends up in your digitized signal.  This makes the signal to noise ratio much worse than it would be if you only had the noise in 1 MHz bandwidth.

 

Worse, if any part of the signal above 1 MHz is narrow-band, like a sine wave or a radio signal, that gets aliased into the digitized signal.

 

Once a component is aliased, it is impossible to to identify which parts are aliases and which are the desired signals.

 

By not having an anti-alias filter, you have almost twice as much noise and the possibility of aliased interferring signals.

 

What is the source of your signal? Is your filter/amplifier shielded? Do you know you have strong radio signals in the area?

 

The resistors need to be connected well. Screw termials or soldering should both work OK.  The resistors are primarily for DC bias currents in the nanoampere or picoampere range.  Shields should be securely grounded.  Whether they need to be grounded at both ends or only at one end depends in complicated ways on the overal configuration of the system and interfering fields.

 

Lynn

0 Kudos
Message 9 of 14
(5,312 Views)

Thanks for your replies.

 

johnsold, I understand your points. The noise data I posted is what I get when I connect leads to the input terminals, and leave them open (that's why I am not worried about the rest of the system yet).

 

Even if I don't connect any source to my board and leave the differential inputs open-circuited with no leads connected to them, I am getting noise.

 

In the latter case, I am getting a high frequency noise of 2 mV pp superimposed on a low frequency waveform.

 

The only way to get rid of it is shorting the input terminals. Then I get a noise of 0.5 mV only. But that's still annoying. I would like to know the source of that noise. Is it normal to have 0.5 mV with the terminals shorted?

 

The university radio station is broadcasting in the building just next door, so that may be the source of the noise, even when I short the input terminals.

 

I want to eliminate that noise before I connect any source to my board.

 

 

To answer your question, my source would be an special inductive probe, for magnetic Barkhausen noise measurements. Since I will be measuring noise, I would like to get rid of any other noise source that I am not in 'control' of.

 

Thanks again for your time.

 

Kind Regards

0 Kudos
Message 10 of 14
(5,309 Views)