Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

how to install ni-daqmx 19 on centos7

Highlighted

os : centos 7.5

ni linux driver : http://www.ni.com/download/ni-linux-device-drivers-2019/8283/en/

 

https://www.ni.com/en-us/support/documentation/supplemental/18/downloading-and-installing-ni-driver-... The installation proceeded as described on the web page, but comes with NI-DAQmx 9.7 version as below.

 

$ lsni -v
Scanning localhost for devices...

System Configuration API Experts found:
NI-DAQmx 9.7 (daqmx)
NI Device Interconnect Manager 19.5.0 (nidim)
NI-CONTROLLER 19.5 (ni-controller)
NI-MXI 19.5 (ni-mxi)
NI PXI Platform Services 19.5 (ni-pxi)
NI-QPXI 19.5 (ni-qpxi)
NI Network Browser 19.0 (network)
NI MX Routing Utility 19.5.0 (nimru)
NI System Configuration 19.5 (nisyscfg)
NI-VISA 19.0 (ni-visa)
NI-RTSI 19.0 (rtsi)

System Configuration API resources found:
localhost.localdomain
--Primary Expert: NI System Configuration 19.5

 

And the usb device is not recognized.

 

What I want is to upgrade to NI-DAQmx 19.5, please help

 

used device : cDAQ-9171, 9230 module

0 Kudos
Message 1 of 3
(323 Views)
Highlighted

Hello, painstar325.

 

Did you notice the installation requirement in description category?

I am pinning screenshot for you. Would be interesting for me to know the results after that step from you.

Regards,

               Hamlet23

0 Kudos
Message 2 of 3
(199 Views)
Highlighted

Also, for your information, your chassis is not supported on daqmx 19.5. Attaching that link and screenshot.

0 Kudos
Message 3 of 3
(198 Views)