Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

failed cRIO 9082 BIOS update

Solved!
Go to solution

Hallo,

 

I tried to update the BIOS of a cRIO-9082, as recommended by NI (desciption can be found using the info code cRIOReboot).

I followed the instructions , but, after the BIOS update process, the cRIO is not able to boot anymore.

So, I'm stucked. Has anyone a suggestion how I can solve this problem?

 

thanks in advance

Pierre

 

0 Kudos
Message 1 of 6
(3,652 Views)

Hi Pierre,

 

By any chance are you still able to enter into the BIOS utility by pressing DEL following a power cycle? Also, when you were installing the BIOS did the process interrupt at any point, or could there have been a power interruption during the installation? Also, could you share what the PN is of your cRIO-9082 as that might be helpful to investigate this issue further.

 

Blayne K 

0 Kudos
Message 2 of 6
(3,645 Views)

Hallo,

 

I tried indeed to press the DEL key but it didn't help. The cRIO is simply trying for one or two seconds to start (Power LED on during that time) then waits something like 5 to 10 seconds iddle (no LED on) and restarts the cycle...

 

I didn't notice any power interruption during the process. It was only at the point 5 of the installation instruction (see http://joule.ni.com/nidu/cds/view/p/id/2932/lang/en ) that, after waiting about five minutes, I tried to reboot that the problem occured...

 

For your information the PN is 151712B-02L 

 

For for your support

Pierre

0 Kudos
Message 3 of 6
(3,642 Views)

Hi Pierre,

 

From your description that sounds like the BIOS may have not gone through completion before your reboot attempt, which may have corrupted your BIOS. Typically the BIOS for the 908x should take only a few minutes to install completely and will look something like the following image when the process nears completion:

 

BIOS update.png

 

Following the FLASHDOS.bat procedure, the controller will automatically reboot and then display that a first boot is detected and that BIOS setup values are reset to defaults. The only recommendation I can share with you now is to attempt to reset some of the BIOS configuration settings manually (in the event they were corrupted nearing the end of your BIOS installation) via the RTC reset switch seen below. To do this, please ensure that you follow these steps: (1) Fully power off your system, (2) Disconnect the 908x from the power supply, (3) Press the RTC switch firmly down and then release, (4) reconnect the power supply and attempt to reboot the system.

 

RTC Reset.png

 

If the controller continues to fail at this point I would advise you to consider proceeding with an RMA for the controller as the BIOS related circuitry will need to be manually reprogrammed and this can only be done via a return. If you do not have a direct point of contact either through support channels at NI or a sales representative please let me know and I will try my best to assist you.

 

Regards,

Blayne K

0 Kudos
Message 4 of 6
(3,635 Views)

hi Blayne,

 

thanks for the suggestion.

Well, pressing the RTC switch didn't help.

 

So, I guess, I shall go for an RMA (return material authorization).

 

thanks anyway for your support.

 

with my best regards

Pierre

0 Kudos
Message 5 of 6
(3,626 Views)
Highlighted
Solution
Accepted by topic author HB-EUM
08-27-2015 04:09 PM

--> The CRIO-9082 is RMA

 

CLOSED

--> I work for KUDOS <--
Message 6 of 6
(3,624 Views)