Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

creating configuration file drives me crazy

I am truying to create configuration file(just store latest settings and load these settings on the program start).

I have used it before for cRIO and had no problem at all.

Right now I am using RealTime system and by some reason I could not manage to create code that does it.

I have attached 2 different code examples. First one has manually chosen path and file name (constant). Code runs OK but does not store anything.

Another is with  File Dialog express vi. It shows error 7 file not found.

It shows this error on the start and on the stop of the program(without showing file dialog)

Possibly my error is very simple, but I spend 2 days truying to figure it out and no luck so far.

Download All
0 Kudos
Message 1 of 8
(2,663 Views)

Does somebody have something to comment it?

I have created small piece of code that tdoes recording of one variable and it works.

After that I have copied this code into big code(main code with real-time control)  after that I immediately have got this lovely message about Error7.

Is it a bug in LabView or is that just me?

0 Kudos
Message 2 of 8
(2,630 Views)

Hi Sergey,

 

I have run and looked over your code.  After running some searches I would like to point you in the direction of this web article which seems to hold the information required to fix your application.

 

http://ae.natinst.com/operations/ae/public.nsf/webPreview/7C012A8ADEBEF7A786256C2100804C01?OpenDocum...

 

Regards,

Message Edited by DThomas on 10-06-2008 03:03 PM
Daniel T
Applications Engineer
National Instruments UK & Ireland
0 Kudos
Message 3 of 8
(2,616 Views)

Thanks Daniel,

but for some reason I could not open this document(link) .

0 Kudos
Message 4 of 8
(2,586 Views)

The following is the information in the link

 

 

Why am I Getting 'Error 7: File Not Found' When Dynamically Launching a VI on a LabVIEW RT System through VI Server?

Primary Software: LabVIEW Modules>>Real-Time Module
Primary Software Version: N/A
Primary Software Fixed Version: N/A
Secondary Software: N/A


Problem:

I used FTP to transfer a VI to my networked Real-Time system. From an application running on the host, I am trying to launch this VI through VI Server. However, the Open VI Reference.vi returns "Error 7: File Not Found".

Solution:

Check to make sure that the VI on the Real-Time system is compiled in the same version of LabVIEW as the one that is running on the host. If there is a version conflict, then VI Server cannot open the VI. The solution is to open the embedded VI in the host LabVIEW version, save it, and then FTP the newly compiled file back to the remote Real-Time system. This will resolve the version conflict and allow VI Server to execute.

Related Links:

Developer Zone Example: Using VI Server to Run LabVIEW Real-Time VIs Stored on an RT Series Hard Dri...

Developer Zone Tutorial: VI Server between the Host PC and Real-Time Series Hardware

Daniel T
Applications Engineer
National Instruments UK & Ireland
0 Kudos
Message 5 of 8
(2,583 Views)

Thanks for a really fast response.

I did take a look  at one of the links on a bottom of your post

Using VI Server to Run LabVIEW Real-Time VIs Stored on an RT Series Hard Drive

(cant open another one)   . Looks interesting but I can't  open code attached 203620.zip

 As it says that it is too old version(I believe LAbView 5.1).

Anyway how it is going to help me?I currently looking intodifferent problem, may be configuration file will be irrelevant after solving it.

http://forums.ni.com/ni/board/message?board.id=280&thread.id=4770

 

Sergey.

0 Kudos
Message 6 of 8
(2,580 Views)
Dear Sergey, My applogies for the incompatibility of those attached files. I will look into your new thread as I believe we can get further with that. Regards
Daniel T
Applications Engineer
National Instruments UK & Ireland
0 Kudos
Message 7 of 8
(2,577 Views)

That would be great.

I have tried to send same code to local NI engineer yesterday but he did not respond to me yet (probably too many stupid questions).

0 Kudos
Message 8 of 8
(2,575 Views)