Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

cRIO9035 unable to deploy the settings to AKD drive

Go to solution

I am working with an AKD drive with NI Softmotion on a cRIO9035 controller. I followed the steps described in:

I have configured the drive to work in EtherCat mode, but I can not find the device in NI MAX.

Also, I am able to add the axis in the project, but after I configured the settings of the axis and try to deploy, I got the following conflict message:

"At least one deployed item is no longer in the project."

Then I tried to compare the project and system, I found that I can not see the axis and EtherCAT master in the system. Is this because that the AKD drive is not communicating with the Softmotion? If so, why I can add the axis to the project?




0 Kudos
Message 1 of 5

Sounds weird. Can you format and reinstall your cRIO-9035, then try to reproduce the issue again?


You can also try the "Deploy All" function:


0 Kudos
Message 2 of 5

Do you mean to format the memory of the cRIO? That might be my last attempt because I would have to reinstall a bunch of software. Yes, I did try the deploy all function, but got the errors attached.

0 Kudos
Message 3 of 5


Can you provide your LV project to me? I can have a try on my side.

0 Kudos
Message 4 of 5
Accepted by topic author Tianyu91
05-22-2017 01:25 PM

I have solved this problem. It turns out that some software on the cRIO is 16.0 version, while the Labview and NI SoftMotion on the host is 15.0 version. After I reinstalled the software on the target into 15.0, it works perfectly!


Thanks a lot!


0 Kudos
Message 5 of 5