Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

cRIO9031 features not available

Solved!
Go to solution
Highlighted

I use Labview2015 to program on cRIO-9031. But when I set up the project and after the device, there is a note that "features not available" and the model cannot run normally. The problem is shown as the picture below. Can someone give some help on this? Looking forward to reply!cRIO_features_not_available_help.PNG

0 Kudos
Message 1 of 9
(4,079 Views)

Has this chassis worked previously?

 

When you right-click on the cRIO-9031 in the project window and select "Connect", does it show an error message?

0 Kudos
Message 2 of 9
(4,068 Views)

      Thank you for your attention!

      Yes, this cRIO has previously been connected with another computer and can operate successfully. But I didn't find "connect" in the right-click. I use "deploy" and it shows the following error or conflict. Because of the previous successful running, I don't think the cRIO lack certain software... it seems so strange.      

deploy_error.PNG

Another problem concerned may be that, the model used is an example model. While adding files to the project, I changed path of some vi, as shown in the pricture below. Some of the vi are not in the plce where they are exepcted. Will that cause the above error?  Thanks a lot!

vi_conflict.PNG

0 Kudos
Message 3 of 9
(4,063 Views)

There should be a "Connect" option when you right click on the cRIO-9031 RT Controller (not the Chassis, but the item above it). Even though they share the same physical enclosure, they are two distinct items in software. If you can successfully connect to it, the LED next to the controller icon in the project window will turn on.

 

Anyway, it sounds like the controller is missing the Scan Engine software component. Can you go into MAX and install it? You don't need to uninstall anything else, just select the currently installed software set, and then at the next step make sure that the Scan Engine component is checked:

 

Untitled.png

 

The item conflicts due to the changed VI path have nothing to do with the Scan Engine error when you try to deploy the chassis. You will need to make sure that the Model Interface Toolkit is installed in the correct location on this computer.

0 Kudos
Message 4 of 9
(4,047 Views)

Thanks a lot!

 

I've installed the NI Scan Engine,but it doesn't work. And because of the previous successful operation when connected to other computers, I don't think the problem has something to do with the softwares in the cRIO.

 

I guess the key of the problem is on the drivers for cRIO or the installing of Labview. I just set up a new device but cannot find "connect" option in the right click menu.Is there something wrong when I set up the new project or,  is it because I lose some necessary blocks while installing Labview or the drivers of CRIO? 

 

Thank you for your attention!

labview_features_not_available.jpg

0 Kudos
Message 5 of 9
(4,035 Views)
Solution
Accepted by topic author weily411
01-14-2016 11:12 PM

That's interesting. I think you're on the right track. Given the other missing dependency issues that you mentioned, the software installation on your computer may be corrupt.

 

You could try repairing it: Go into the Windows Control Panel, open Programs and Features, double click on National Instruments Software, select the NI Labview Real-Time Module and then click Repair. As a last resort, you could uninstall/reinstall LabVIEW, RT, and NI-RIO.

0 Kudos
Message 6 of 9
(4,022 Views)

Uh...Thank you for your reminding.....

 

Actually I didn't notice that I hadn't  installed Labview Real-time  until seeing this reply. Smiley EmbarassedAnd after I  installed Labview Real-time, everything is riight~

 

Thank you very mucn! 

0 Kudos
Message 7 of 9
(4,011 Views)

it doesn't show an error message

0 Kudos
Message 8 of 9
(2,417 Views)

Hi,

I'm working with Labview 2017 and cRIO-9067 and i have the same problem ( Features not available)  i tried to repair and reinstall LabView Real-Time, NI RIO, but i still have the problem.

  • this chassis worked previously
  • When i right-click on the cRIO-9031 in the project window the connect option doesn't appearUntitled.png

 

Could you help me please!!

 

 

0 Kudos
Message 9 of 9
(2,355 Views)