Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

cRIO not seeing NI9871 on MAX

I recently purchased cRIO 9056 with NI 9871 and Labview (and 9472, 9421, 9203, 9266 - that all works fine). But I cannot see the 4 ports of the NI 9871 as you can see on the clip below. I tried to follow: Install NI Software on Your CompactRIO Controller - National Instruments but all SW seems fine. I also tried to update in the Software section in "My System".

I am also worried about the small warning triangle on cRIO. 

Please better ideas?



0 Kudos
Message 1 of 8



Looking at the installed software list, you do not have -  the NI-Serial 9870 and 9871 Scan Engine Support and NI -Serial installed on your RT controller hence you can't seen the ports.


Refer to this link install the same -


I hope this solves the issue.

Dharani | CLA | CTD
0 Kudos
Message 2 of 8

thanks, I tried to follow the link instructions, but it does not look exactly the same. anyway, below are clips from the SW I, now, have installed, what i am suggested, how the labview project and the max viewer looks. I hope you can help me get it to work.



0 Kudos
Message 3 of 8



That's all, It's working now. I can see the serial ports of the module in NI MAX. Please note that, you will not see serial ports in LabVIEW project like other modules (NI 9472) in the project. When you use VISA API's you will see the serial port names same as the NI MAX serial port names. Here is an example:


I hope this helps.

Dharani | CLA | CTD
0 Kudos
Message 4 of 8

Hi - thanks again,

but i am still a little lost - i am not able to copy the example you showed. and things look a bit different than on the link Discover, Configure, and Communicate with NI 987x Modules in Scan Mode - National Instruments . MAX looks like this - why do i have 5 ASLR ports? which ones represents the 4 ports and how do i communicate with them? I tried to copy as shown below but with no success (couldn't drag - simply copied the name ASLR... into the field)

br Jørn




from the knowledge-link: 





0 Kudos
Message 5 of 8


To answer your questions,


why do i have 5 ASLR ports?

  • It's because, you have one onboard serial port. USB Type-C, device port with Console Out

which ones represents the 4 ports and how do i communicate with them?

the above link also talks about the serial port test from LabVIEW as well as from NI MAX.


I hope this helps.

Dharani | CLA | CTD
Message 6 of 8

thanks again for your fast replys - but i am a dense guy, so it takes some time to get it working for me. the readback would not work for me as i have an ethernet (j50?) connection. anyway, i tried the example vi and i was able to see the VISA resource names - but i got an error on the VISA Read as you can see below:


can you explain why?

br Jørn


0 Kudos
Message 7 of 8

What you are seeing is timeout error. It is mostly due to improper connections (tx -> rx). 


  1. Make sure you have RJ50 to DB9 cable from NI (Ex. PN 184428-0X)
  2. You must connect an external power supply to the NI 9871. External voltage source (of +8 V to +28 V) and the NI 9871. Refer to page 9 -
  3. Set the flow control to off (if you are using flow control, remember to short  (cts->rts) 2->3, 6->7)
  4. Short pins 4->8 and 5->9 as shown below and run the LabVIEW example/MAX VISA test panels.
  5. You should received the transmitted data (TX->RX)

Serial loopback.png

Dharani | CLA | CTD
0 Kudos
Message 8 of 8