Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

cRIO: No Ethernet driver found in ethernet config file

Solved!
Go to solution

Hi,

 

I have a brand new cRIO-9081 that I am setting up in MAX. When I open MAX, the cRIO does not show up. I tried the basic troubleshooting methods but without success.

 

I attached a VGA cable to the console out on the cRIO and connected it to a monitor. I get an error message stating there are no ethernet drivers found in the ethernet configuration file.

 

Without being able to connect to the hardware in MAX, I am unable to format the drive and reinstall the RIO drivers.

 

How else can I get the ethernet drivers installed so that I can gain access to the chassis?

 

Any help is appreciated.

 

Thanks,

Cory

0 Kudos
Message 1 of 4
(1,855 Views)

that normally does not happen. You don't need to install ethernet drivers, that should be part of the firmware. I would call  support and send it back

0 Kudos
Message 2 of 4
(1,802 Views)

I would also recommend contacting support for this. This is very odd and unexpected

 

http://www.ni.com/en-us/support.html

0 Kudos
Message 3 of 4
(1,796 Views)
Solution
Accepted by topic author CWT52

Update: The firmware on my cRIO's SSD was corrupted.

 

We have another de-comissioned cRIO-9081 that we were able to swap the SSD and everything worked as expected. I was able to connect to MAX and download the RIO-17.0 drivers, set IP addresses, etc.

 

I am sure there may be things embedded in the firmware directly associated with the chassis, and some would strongly encourage I do not take this approach; however, I cannot justify the $1800 NI quoted me to perform this repair (Even though the cRIO was brand new in the packaging, it was purchased in 2015 so it was out of warranty). I'm not trying to bad-mouth NI as I know they have standard business protocol, just commenting on why I went with this workaround.

 

Thanks for the feedback.

 

 

0 Kudos
Message 4 of 4
(1,787 Views)