Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

cRIO - Laptop connection fails on particular Laptop

Hi all,


When a collegue of mine uses his laptop to make a direct connection with a cRIO, using an ethernet cable, the connection gets established.

However, when I trie to do the same thing with my laptop, using the same ethernet cable, no connection can be made.


What's even more strange is that I do can make a connection to that cRIO using my laptop, but not direct, only via the local subnet. (Both my laptop and the cRIO connected to the same physical subnet).


We used exactly the same ip-adres and subnet-mask on our laptop, and also the cRIO's network-settings were left unchanged.

The only thing that differs on both laptops are the LabVIEW module versions.


How is this possible??


Thanks in advance.



0 Kudos
Message 1 of 5

Hi Marco:


What do you mean by a connection can be established?  Does this mean you can see the controller in MAX or does this mean you can connect to the controller in your LabVIEW project?


To help us troubleshoot the issue, please specify which versions of LabVIEW Real-Time and NI-RIO installed on your laptops as well as on the cRIO.  Also, please provide the network settings you're using on the laptops and the cRIO.  If you're able to connect over the network but not directly, it sounds like it's due to your network configuration.

Alex Person
NI-RIO Product Support Engineer
National Instruments
0 Kudos
Message 2 of 5

Hi Alex,


What I mean is, a Host VI on the laptop of my collegue can make connection to a Slave VI on the cRIO, which exchange date through a TCP/IP socket connection.

Both VI's were build as executables. The Slave VI on the cRIO is configured to run at startup of the cRIO.


There are 2 ways I made the physical connection from my laptop to the cRIO:

1. Indirectly over the network:

     - I can connect to the Frontpanel of the Slave VI running on the cRIO (either using Remote Panel Connection or Internet Explorer)

     - I can't use the Master VI running on my laptop to connect with the cRIO's Slave VI


2. Directly using an ethernet cable:

     - I can't connect to the Frontpanel of the Slave VI running on the cRIO 

     - I can't use the Master VI running on my laptop to connect with the cRIO's Slave VI


The port number which is used for the TCP/IP connection between Master and Slave VI's is 55555.


In attachement you can see the current software installed on the cRIO and my laptop.

The network settings are:

*On my laptop:

- only 1 network adapter On:

     - ip-adres:

     - subnetmask:

- (inderict connection to the cRIO over the network)

*On the cRIO:

     - ip-adres:

     - subnetmask:

I can't tell the network-settings and software-versions of my collegue's laptop at the moment, because he is out his office.






Download All
0 Kudos
Message 3 of 5

Hi Alex,


I now already fixed one problem: the connection with ths Slave VI on the cRIO using the Master VI on my laptop. Thsis was a little bug in the Master VI (a storage folder on the laptop had to be created by the operator first).


However, there is still a problem with the direct connection, which still doesn't allow any connection at all (even not in MAX).



0 Kudos
Message 4 of 5

Allright, the problem with the direct link between cRIO and Laptop is also solved.

This was caused by an old driver of the network adapter on my laptop, who didn`t support autodetection of ethernet-cable type.


Problem solved.

0 Kudos
Message 5 of 5