Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

cRIO-9066 - Not detected by Max

Solved!
Go to solution
Highlighted

Hello All

I am trying to setup cRIO-9066 for SW development. I am running Windows 10, 64-bit.

 

When I first connected cRIO to my machine, I was able to see it via Max, but i was unable to install any SW. So I upgraded these packages to versions below

- CompactRIO 19.1

- NI Max 19.0.0.f0

- NI R Series Multifunction RIO 18.0

 

I also installed latest copy of Real-Time and FPGA. After these installations, NI can't even see my cRIO. I tried to add via its IP address and this is what I see. I am not sure what SW the cRIO is expecting. I want to see if there are suggestions outside uninstalling and reinstalling which seems to dominate similar issues. Thanks for your help.

 

Capture1.PNG

 

 

 

 


Kudos are the best way to say thanks Smiley Happy
0 Kudos
Message 1 of 3
(173 Views)

Hi winterishere8,

Formatting the controller and reinstalling software is likely the fastest way to get up and running.

You could also try the troubleshooting steps in the link below:

NI CompactRIO or Network Device Doesn't Show Up or is Missing in MAX

https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000P70YSAS&l=en-US

Jiwhan S.
Technical Support Engineer
National Instruments
0 Kudos
Message 2 of 3
(119 Views)
Solution
Accepted by topic author winterishere8

I found it had to do with activation. I tried to use 2018 LabVIEW / FPGA / RT / cRIO SW, but it looked like when i downloaded version meant for 2019, Max wasn't able to detect my cRIO. I uninstalled all versions compatible with 2019 LabVIEW and installed them for 2018 and everything works now. Didn't realize there were so many version compatibility issues. I assumed that only a minimum version was the criteria, but it looks like versions are a bit more stringent with cRIOs.


Kudos are the best way to say thanks Smiley Happy
0 Kudos
Message 3 of 3
(109 Views)