Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

cRIO 9066 NIC Addressing Type Mysterious Reset??

I received a call from a customer who was unable to connect to their cRIO 9066 chassis over Ethernet (default) so I went to their location to investigate.

 

When I arrived, I was unable to connect to the chassis over the primary NIC using MAX, pinging the chassis, WIF, and, LabVIEW using the last known STATIC IP address. I ended up connecting via the USB port to discover that the chassis had its primary NIC addressing type set to DHCP, not the expected STATIC type. I reset the addressing type and the address to what it should have been and all is well.

 

My question is this - Is there anyway that the cRIO RT could have reset its primary NIC addressing type from "static" to "DHCP" without user intervention? I have dealt with these chassis for a very long time and this is a first for me. There are no switches other than the "Reset" switch, so an IP RESET could not have been performed. The chassis was not in "safe-mode" when I arrived. Actually, everything appeared to be operating normally other than the WIF and MAX couldn't see the chassis.

 

I am considering using the ".local" address for the chassis in case this happens again, but I am unsure if that would work if the host and cRIO are addressed on separate sub-nets.

 

Sincerely,

STUMPED

0 Kudos
Message 1 of 4
(872 Views)

Hello Drew,

 

I looked into the getting started guide for the cRIO 9066, and on this page it looks like the cRIO initiates a new DHCP connection on start-up, or if the reset button is held down for 5 seconds (on next page).

Message 2 of 4
(842 Views)

Thanks for the information. I asked the customer if it was possible the reset button was long pressed twice.

0 Kudos
Message 3 of 4
(836 Views)
Highlighted

This seems like the likely cause. Otherwise, I'm not sure why it would change to DHCP mode. 

0 Kudos
Message 4 of 4
(831 Views)