Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

cRIO-9038 Satus LED is continiosly blink

Go to solution

On my controller cRIO-9038 (it was in storage for a long time, I don't know the background) Status LED blinking continuously yellow color. I read that this means unrecoverable software error.
Power led is green. No signal on monitor and USB host is not detected. The Ethernet LEDs are blinking fine. The Status LED glows yellow when powered on, after 50 seconds it blinks.
I tried to solve this problem in the following ways:
1 Restore firmware according to the instructions
No result: after power up the Status LED is yellow, after 50 seconds it starts blinking.
2 Reset OS according to the instruction:
I have tried 2 ways, preparation of flash via MAX, and the way through the archive.
Same result: Status LED glows yellow, after 50 seconds it starts blinking.
Any other ways to restore the software?

0 Kudos
Message 1 of 3



I got a 9038 second hand. I was updating the software to be compatible with the NI-MAX, so I am able to play a little bit with it, and seem to be OK.

Then I try to install X-NET. While the update was going on, it gave me an error message and then started to continuously reset with the second LED blinking yellow in the same way that you mention.

It was stuck in a cycle or restarting. Things began to improve when I connected to a VGA monitor (not a DVI port, as is slow and you do not see what is going on).

I saw the BIOS set up. I play with those things for long, but I could not fix the errors.



Then I found your link, and the one that work was the following:


I did the USB drive, it restarted wrong as before, but I went to get water and when I returned, it did the steps by itself, and ask to remove the drive and now boots OK and I see it on NI-MAX.


Hope that this helps.




PS: Use a Mini-DP to VGA and a USB keyboard with cable for best results.


0 Kudos
Message 2 of 3
Accepted by Feds

I solved the problem.
1 There was no signal on the monitor because my minidp-hdmi converter does not support small resolutions. I connected with a miniDP-DP cable to the monitor: I entered the BIOS.
2 The OS would not boot and would not restore because the internal SSD was damaged. SATA AHCI controller does not show up in BIOS. Installed windows - hardware error controller error in device manager. It's broken, obviously. According to the datasheet on the processor though, it's built in. How could it be broken?
3 The solution is to put in a USB-SATA converter or use a USB SSD. In short, a non-removable media class device. Then NI Linux rt installs normally.

Message 3 of 3