Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

VISA ERROR: 0xBFFF00A7 (VI_ERROR_MACHINE_NAVAIL)

Highlighted
Hi everyone. We are trying to configure CompactRio(controller 9004, chassis 9103, CompactRio module software 2.1.0, Labview Real Time module 8.2)  with MAX version 4.1.0.3001, and a VISA ERROR with the following code 0xBFFF00A7 (VI_ERROR_MACHINE_NAVAIL) is given. We don't know the cause of this VISA ERROR nor what should we do in order to avoid it. We have done all the steps given in the VISA ERROR help and we have checked all the possible causes specified:

1. The remote machine name may be incorrectly specified (either the name was misspelled or the wrong IP address was typed in).
2. The remote machine may not be turned on.
3. The VISA server  has not been started on the remote machine.
4. The VISA server was started but is either suspended or is no longer running on the remote machine.
5. Either the local machine or the remote machine is not connected to the network.
6. There is a network configuration problem, such as an improperly assigned IP address, an incorrectly configured routing table, or a firewall between the local and remote machine.

We do not know what more to do. We hope you will be able to help us.

Thank you.

Ander
 
0 Kudos
Message 1 of 7
(4,349 Views)
Highlighted
Hi Ander,
 
I think you can find this link very useful. Please have a look at it and let me know if it helps you solve the issue.
 
Regards,
David Oña
0 Kudos
Message 2 of 7
(4,332 Views)
Highlighted

We are experiencing the same error.

 

Hardware Config:

 

- Custom LV-RT PC (dual Xeon Quad core on the TYAN motherboard recommended by NI)

 

- 2 X PCIe1427e framegrabbers

 

- 1 X PCI-6254 MIO

 

- 1 X PCI-8433 Serial board

 

All of the devices work as expected except the 8433 serial board. When we try to run the VISA Test Panel from MAX, we get the dialog with error no. 0xBFFF00A7. Validating the port configuration seems to work fine, but the Visa Test Panel shows an error.

 

In LabVIEW, no error is reported, but it just doesn't work.

 

We have checked all of the usual causes (Firewall, VISA Server, software version conflicts, etc.), but nothing appears to be wrong.

 

Is there any issue with using this board under RT? We aren't sure if it's a software problem or a hardware conflict.

 

Any advice?

 

Thanks!

 

D.

0 Kudos
Message 3 of 7
(3,860 Views)
Highlighted

Hi,

I've been experiencing the same VISA error, but using the following hardware as a remote host:

-Power Supply TDK Lambda, model GENESYS 60-55.

-LAN card using static IP address.

Using a Lambda web application, the device runs normally, but I am interested in controlling the power supply via VISA to integrate it in a CVI environment.

 

Any suggestion would be appreciated.

 

Andres


@Ander wrote:
Hi everyone. We are trying to configure CompactRio(controller 9004, chassis 9103, CompactRio module software 2.1.0, Labview Real Time module 8.2)  with MAX version 4.1.0.3001, and a VISA ERROR with the following code 0xBFFF00A7 (VI_ERROR_MACHINE_NAVAIL) is given. We don't know the cause of this VISA ERROR nor what should we do in order to avoid it. We have done all the steps given in the VISA ERROR help and we have checked all the possible causes specified:

1. The remote machine name may be incorrectly specified (either the name was misspelled or the wrong IP address was typed in).
2. The remote machine may not be turned on.
3. The VISA server  has not been started on the remote machine.
4. The VISA server was started but is either suspended or is no longer running on the remote machine.
5. Either the local machine or the remote machine is not connected to the network.
6. There is a network configuration problem, such as an improperly assigned IP address, an incorrectly configured routing table, or a firewall between the local and remote machine.

We do not know what more to do. We hope you will be able to help us.

Thank you.

Ander
 

 

0 Kudos
Message 4 of 7
(3,358 Views)

I am experiencing a problem very similar to what you described with a cRIO-9030.  Did you find a solution to the problem?

0 Kudos
Message 5 of 7
(2,359 Views)
Highlighted

Hi, 

This link no longer works. Is there another link to use?

ammarbabikir_0-1582989046688.png



Thanks, 
Ammar

 

Message 6 of 7
(533 Views)
Highlighted

I am also facing a similar issue. I am trying to establish serial communication between cRio-9040 and Newport motion controller ESP301 via RS232 to RJ50 cable. The NI MAX throws VISA ERROR  0xBFFF00A7. The labview doesn't throw any error but there is no response for the serial commands. Has anyone found a solution yet?

0 Kudos
Message 7 of 7
(255 Views)