Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

Using onboard CAN / CAN-FD port on the sbRio-9609/9629 FPGA - how to use ?

Go to solution


I am trying to use the onboard CAN Port on the sbRIO 9629 to communicate with 2 receivers but am unable to detect any output signal from the CAN port (scoping the CANH and CANL lines on a oscilloscope shows no signal whatsoever).


What I have tried:

I have tried to modify and use the FPGA API "LOW_LEVEL_CAN"  (picture attached) available with no success. The analog output in the VI serves as an indicator of FPGA functionality and loop completion. It has compiled and runs onboard. The iterations are incrementing, but still no CAN output. As the CAN port is only accessible through the FPGA (as shown on the 9629 system block diagram) I cannot use the or CANRead.Vi from the RT processor. I am using LabView 2019 SP1 and have updated my drivers to v20.50 as recommended on the specifications data sheet. The questions I have are listed below. Any help or guidance would be appreciated.



  1. Is there some setup required in NI MAX or in the NI project explorer to enable the usage of the CAN port? A picture of my current project explorer outline is attached as a png. 
  2. Is there something wrong with my LabView FPGA VI setup (.vi attached) ? I have attached an image of the current FPGA VI I have built as well
  3. Is there some example using the available CAN bus API ? I have been unable to find any documentation on the "LOW_LEVEL_CAN" API available in LabView with this device (pic of this API attached). The "Help-> Find Examples" tab does not have any examples with the same CAN modules/API/interface. 



Message 1 of 3

I have exactly the same issue.

0 Kudos
Message 2 of 3
Accepted by martyRoboDes

 Turns out the solution was that I had to update LABVIEW to 20.0 (the online datasheet for the 9629 needs to be updated to indicate that LABVIEW 20.0 is required for this device) and install the new driver for CAN. This then exposed the CAN0 module on the FPGA. From there on reading, and writing to onboard CAN works smoothly. The option for CAN shown in the images above has no use from what I discerned. 

0 Kudos
Message 3 of 3