Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

Unable to reset password of cRIO-9067 with recovery.cfg

Go to solution


I forgot password of my cRIO-9067. I called NI Technical Support, they sent me the file "recovery.cfg", and I followed the the steps below:

This recovery process only applies to NI Linux Real-Time controllers. Typically the safe mode utility should be used. 

To use the utility with your controller you will need a FAT16 or FAT32 USB drive with FAT on the first partition. Follow the steps below:

  1. Obtain a FAT16 or FAT32 USB drive with FAT on the first partition.
  2. Copy the provided recovery.cfg file to the thumb drive.
  3. Plug in the USB drive to the controller.
  4. Power off the target by unplugging the power.
  5. Press and hold the reset button while completing the next two steps.
  6. Power on the target by plugging the power back in.
  7. Once the status light turns on, release the reset button.
  8. Wait for the controller to boot. This should take less than a minute.
  9. Check that the password has been reset to the default. Note: you will still be prompted for a password even though the default is blank.
    • In certain situations, you may need to force the system into safe mode to make the controller accessible. Follow the instructions in your device manual to manually boot into safe mode.
  10. Format and reinstall software to the target as most of the configuration files that are created for LabVIEW Real-Time will be removed in this process.

However, after I finished step 7, the STATUS LED Indicator blink continuously and cannot stop blink. So I cannot reset the password successfully. Should I transform cRIO-9067 to Safe mode before step 1? But I think after Power off (step 4), the Safe mode will lost. Actually, I also do this, but it didn't work.

I want to konw what should I do.

0 Kudos
Message 1 of 6

I have tried another two USB drives, I also format them either FAT32 or exFAT. All didn't work.

0 Kudos
Message 2 of 6
Accepted by topic author RongweiWen

Finally, I succeeded. The Technical Support sent me a file which can not only reset password but also update firmware. I test 7 USB drives with this file. Finally, a FAT32 TOSHIBA 16GB USB drive works very well.

Message 3 of 6

I have exacted the same problem. Exact the same type of cRio and I have tried exactly the same that you have tried. From where you have obtained the recovery file that the technical support has provided you.


Thank you in advance!!!

0 Kudos
Message 4 of 6

I cannot reset my crio.  Contacted NI support. They sent me a link to a file. I followed the instructions (tried 3x), but it doesn't work. On the forums. This appears to be a common problem. A solution is stated that the file needs to include a firmware update as well as resetting the cRIO. I have sent multiple requests to NI, left 6 voice mails and gotten zero response. If anyone can help me, I would be very grateful. Specifically, where can I get this file?

Who is John Galt?
0 Kudos
Message 5 of 6



The cRIO-9067 runs the NI Linux RT ( The easiest way to reset the password is to format the controller from NI MAX and reinstall the runtime OS and software.


The .cfg files are used to reset cRIOs running VxWorks, and are no longer sold. 

David C
0 Kudos
Message 6 of 6