Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to flash a roborio, Error -2147220335 occurred at nisyscfg.lvlib:Format 5.3.vi:2890001

Solved!
Go to solution

I am attempting to flash an FRC RoboRIO.  There's a solid power supply to the device, a USB cable to a computer running roboRIO imaging tool.  On startup the imaging tool finds the RoboRIO fine, and begins the reformatting process.  Everything looks good, progress bar advances, and a few minutes in I get the above error.

From the error message:

Possible reason(s):

 

NI System Configuration: System failed to restart after the hard drive was formatted.  The system is in an unknown state.  You may have to manually restart the target.

 

Complete call chain:

nisyscfg.lvlib:Format 5.3.vi:2890001

RoboRIOImagingTool.lvlib:Reconfig Device.vi

RoboRIOImagingTool.lvlib:ImageManager.vi

RoboRIOImagingTool.lvlib:ImagingToolMain.vi

 

Status: Corrupt firmware, cannot run.

 

-----------

Any help to get this RoboRIO back on it's feet again would be much appreciated.

0 Kudos
Message 1 of 6
(1,405 Views)

Additional data about this problem:

I am able to contact the RoboRIO via USB cable (No networking connected), using web browser connected to 172.22.11.2.

System Status:

cpeppler_4-1581602736826.png


Started Imaging tool as administrator.
Attempt to update firmware:

cpeppler_0-1581602302036.png

Result:

cpeppler_1-1581602435103.png

Attempt to flash new image:

cpeppler_2-1581602503805.png

Result:

cpeppler_3-1581602535572.png

Attempt to enter safe mode holding reset button:
Continuous blink...contact NI Tech support.

0 Kudos
Message 2 of 6
(1,351 Views)

My team is having the same issue. We were a 2020 beta team and updated our RoboRIO to the beta firmware. After the season started, we attempted to format to the 2020 image and ran into the error you described above, with the orange status light flashes continuously at a constant interval. A similar error occurs when we try to update firmware. 

 

We've followed all of the suggestions listed in the error message but to no avail. Rebooting in safe-mode causes the status light to flash continuously again, which the manual states is an unrecoverable error. 

Interestingly, the RoboRIO works fine when we don't try to update. Driver station can connect without a problem, but we can't deploy this year's code because the firmware is too old. I can even use the FRC RoboRIO Imaging Tool to "Edit Startup Settings" and it works like a charm. 

I've called the NI FRC support number listed in the WPILib docs and waited on hold for an hour or so at a time, but no one ever picks up. I leave a message, but never get a call back. I'm pretty disappointed with NI's level of support. Especially since no one wants to respond to threads like this.

0 Kudos
Message 3 of 6
(1,306 Views)
Solution
Accepted by topic author cpeppler

Just to close out this issue, I did get on the phone with an NI support representative, pretty quickly got him to the point that he realized I'ld done my homework, and that the RoboRIO needed to be reset to factory settings.  He setup something in his support system, and got back to me with a file (specific to the team and team number, I believe), that I put on a freshly formatted thumb drive.  I plugged that thumbdrive into one of the USB ports (needs to be the correct one, I forget which one now.  I tried the first, it didn't work, tried the second and it did).  The roborio went back to it's factory state, and from there I was able to reflash to the updated firmware, and from there, was able to apply the most recent image, and bring the RoboRIO back to life.  It's a bit of a process, but it did eventually work.  

Message 4 of 6
(1,303 Views)

Glad to hear. I'd been calling NI support in the afternoon, but I tried calling again this morning and finally got someone to pick up. They will be sending me a recovery script soon.

0 Kudos
Message 5 of 6
(1,297 Views)

Unfortunately the recovery script did not work. NI will be replacing our RoboRIO

0 Kudos
Message 6 of 6
(1,277 Views)