Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

Unable to Get VISA Remote Passport Working on cRIO 9030

Go to solution

I am trying to access the VISA resources on one cRIO from another, and despite everything I've tried I get the error:


Error -1073807192 occurred at VISA Open in visa
Possible reason(s):
VISA:  (Hex 0xBFFF00A8) Access to the resource or remote machine is denied. This is due to lack of sufficient privileges for the current user or machine.


I installed VISA Server on the cRIO I'm trying to access and VISA Remote Passport on the client (I actually went ahead and installed VISA everything on both just to check). I went into VISA server settings on the cRIO I want to act as a server and explicitly added the client's IP address, I also added * just to be safe, but the error persists.


I have no issue accessing the remote resource via VISA Remote Passport from my PC, I just cannot do it from a cRIO. Stranger still, I cannot access a local VISA resource through VISA remote passport. is my desktop is the server cRIO is the client cRIO

In VISA server settings on the server, I gave access to,, and *. The following code returns the error when run on either the client or the server cRIO, but successfully opens the resource when run from my Desktop

VISA Test.png

I also tried to get the cRIO to access anything using the remote URLs (COM ports on my PC etc.). Every target I tried to access I added the cRIO's IP and * in the Server settings (and saved them). I have no issues accessing any remote resources from my PC.


Both cRIOs are running CompactRIO 17.0. I tested with CompactRIO 15 in case it was a recent issue, but I had the same problem.


Am I missing something?

0 Kudos
Message 1 of 3

I added a 3rd cRIO to the mix, this one a 9012, and it is able to successfully access VISA resources on the 9030s. So I can successfully use VISA Remote Passport on everything but the 9030s.

0 Kudos
Message 2 of 3
Accepted by topic author DavidBTaylor

My coworker may have found the cause:


I'm going to try out the recommended fix.

0 Kudos
Message 3 of 3