Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

USB-7845R DIO Issues

Go to solution

I have a USB-7845R connected to a relay board and I noticed some digital outputs not setting correctly with the software.  The application has a mix of inputs and outputs and I'm primarily using the I/O node to configure the direction, but I've tried the "Set Output Enable" and "Set Output Data" method nodes as well.  All 32 DIO in Connector 0 appear to work , but only 12/16 in Connector 1 are driving the outputs.  Specifically these are DIO8, DIO10, DIO12 and DIO14 and they are oddly all separately grouped on the connector.  I am using the recommended SH68 cable with a SCB-68A terminal.


I tried another brand new 7845R with the same code and swapped cables as well, both yielding the same result.  The project was started with an FPGA template and auto generated from the attached device.  The code is very simple as shown in the snippet below.  The environment is Windows 10 with LabVIEW 2020 and FPGA Module 2020.



Does this seem like a configuration issue or something I'm missing with assigning these lines as outputs?



0 Kudos
Message 1 of 4

@deveh wrote:

I have a USB-7845R connected to a relay board and I noticed some digital outputs not setting correctly with the software.

Are you trying to directly control the relays with the digital outputs?  The current capacity of the digital outputs from this board are not likely strong enough to driver a relay.  You will need a buffer circuit of some type that can supply the current required for your relays.

There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
"Not that we are sufficient in ourselves to claim anything as coming from us, but our sufficiency is from God" - 2 Corinthians 3:5
0 Kudos
Message 2 of 4

Thank you for the response.  I should have added that the board is designed such that the FPGA outputs drive MOSFETS before the relays.  When I wasn't getting those to fire I disconnected the board and I'm not even getting a signal on an open output.

0 Kudos
Message 3 of 4
Accepted by topic author deveh

Problem solved, it was an cable compatibility issue.  Leaving this here for future reference.

0 Kudos
Message 4 of 4