Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Trouble when downgrading a package in opkg

Highlighted

I'm working with a new IC-3173 with LinuxRT. I have a few binaries from previously compiled OpenCV algorithms that I am trying to run on it. I was able to run them on a CVS 1458RT (which I currently don´t have access to). 

 

If I run "opkg install opencv" it installs OpenCV 3.1. However, the binaries were compiles using OpenCV 3.0, and as far as I know it points to 3.0 shared objects. I looked though the download.ni files and found opencv in the 2016 repos. I modified the feed.conf file so it would point to those, unsinstalled opencv 3.1. 

 

When I try to install opencv 3.0 it installed without the highgui library. and it looks like there is conflict with some installed libraries. I tried the --force-downgrade option in opkg but it still asks to deinstall some of them. I dont know how or even if I should uninstall those libraries. Does anyone have any opinion as to how to install opencv 3.0 on this system? 

 

 

admin@NI-IC-3173-xxxxxxxx:/# opkg install opencv
Solver encountered 1 problem(s):
Problem 1/1:
  - package opencv-3.0+git0+424c2bddb3-r0.9.core2-64 requires libopencv-highgui3.0, but none of the providers can be installed

Solution 1:
  - allow deinstallation of libgdk-pixbuf-2.0-0-2.32.3-r0.94.core2-64
  - allow downgrade of xfce4-panel-plugin-windowmenu-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-windowmenu-4.12.0-r0.82.core2-64
  - allow downgrade of xfce4-panel-plugin-separator-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-separator-4.12.0-r0.82.core2-64
  - allow downgrade of exo-0.10.6-r0.86.core2-64 to exo-0.10.3-r0.58.core2-64
  - allow deinstallation of libgdk-pixbuf-2.0-loader-png-2.32.3-r0.94.core2-64
  - allow downgrade of xfce4-panel-plugin-showdesktop-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-showdesktop-4.12.0-r0.82.core2-64
  - allow downgrade of xfce4-xkb-plugin-0.7.1-r0.60.core2-64 to xfce4-xkb-plugin-0.7.0-r0.257.core2-64
  - allow downgrade of librsvg-2-2-2.40.15-r0.34.core2-64 to librsvg-2-2-2.40.6-r0.60.core2-64
  - allow downgrade of xfce4-notifyd-0.2.4-r0.87.core2-64 to xfce4-notifyd-0.2.2-r0.238.core2-64
  - allow deinstallation of libwnck-1-22-2.31.0-r0.56.core2-64
  - allow downgrade of libgtk-2.0-2.24.29-r0.95.core2-64 to libgtk-2.0-2.24.28-r0.96.core2-64
  - allow downgrade of xfce4-session-4.12.1-r0.83.core2-64 to xfce4-session-4.12.0-r0.97.core2-64
  - allow downgrade of libgtk-3.0-3.18.8-r0.59.core2-64 to libgtk-3.0-3.12.2-r0.228.core2-64
  - allow downgrade of garcon-0.4.0-r0.177.core2-64 to garcon-0.4.0-r0.83.core2-64
  - allow downgrade of xfce4-panel-plugin-systray-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-systray-4.12.0-r0.82.core2-64
  - allow downgrade of libvte9-0.28.2-r6.328.core2-64 to libvte9-0.28.2-r6.268.core2-64
  - allow deinstallation of libgdk-pixbuf-2.0-loader-gif-2.32.3-r0.94.core2-64
  - allow deinstallation of libxfce4ui-gtk2-4.12.1-r0.181.core2-64
  - allow downgrade of gtk-xfce-engine-3.2.0-r0.170.core2-64 to gtk-xfce-engine-3.2.0-r0.81.core2-64
  - allow downgrade of xfce4-panel-plugin-clock-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-clock-4.12.0-r0.82.core2-64
  - allow downgrade of xfce4-panel-plugin-launcher-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-launcher-4.12.0-r0.82.core2-64
  - allow downgrade of xfce4-panel-plugin-directorymenu-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-directorymenu-4.12.0-r0.82.core2-64
  - allow downgrade of xfdesktop-4.12.3-r0.85.core2-64 to xfdesktop-4.12.0-r0.72.core2-64
  - allow deinstallation of libgtksourceview-2.0-0-2.10.5-r0.313.core2-64
  - allow downgrade of xfce4-panel-plugin-pager-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-pager-4.12.0-r0.82.core2-64
  - allow downgrade of libnotify-0.7.6-r0.86.core2-64 to libnotify-0.6.0-r1.259.core2-64
  - allow downgrade of libcanberra-gtk2-0.30-r0.87.core2-64 to libcanberra-gtk2-0.29-r0.276.core2-64
  - allow deinstallation of libgdk-pixbuf-2.0-loader-xpm-2.32.3-r0.94.core2-64
  - allow deinstallation of libgdk-pixbuf-2.0-loader-jpeg-2.32.3-r0.94.core2-64
  - allow downgrade of xfce4-terminal-0.6.3-r0.331.core2-64 to xfce4-terminal-0.6.3-r0.242.core2-64
  - allow downgrade of thunar-1.6.10-r0.86.core2-64 to thunar-1.6.6-r0.74.core2-64
  - allow downgrade of xfce4-panel-plugin-actions-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-actions-4.12.0-r0.82.core2-64
  - allow downgrade of xfwm4-4.12.3-r0.84.core2-64 to xfwm4-4.12.2-r0.74.core2-64
  - allow downgrade of xfce4-panel-4.12.0-r0.184.core2-64 to xfce4-panel-4.12.0-r0.82.core2-64
  - allow downgrade of xfce4-settings-4.12.0+git45+c6683cb2cf-r0.87.core2-64 to xfce4-settings-4.12.0+git28+a4540c2350-r0.81.core2-64
  - allow downgrade of xfce4-panel-plugin-applicationsmenu-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-applicationsmenu-4.12.0-r0.82.core2-64
  - allow downgrade of xfce4-panel-plugin-tasklist-4.12.0-r0.184.core2-64 to xfce4-panel-plugin-tasklist-4.12.0-r0.82.core2-64
  - allow deinstallation of gtk3-xfce-engine-3.2.0-r0.170.core2-64
  - allow deinstallation of libjpeg62-8d+1.4.2-r0.88.core2-64
  - allow downgrade of libxfce4ui-4.12.1-r0.181.core2-64 to libxfce4ui-4.12.1-r0.87.core2-64
  - allow deinstallation of mousepad-0.4.0-r0.154.core2-64
  - allow downgrade of libgphoto2-camlibs-2.5.8-r0.50.core2-64 to libgphoto2-camlibs-2.4.11-r5.159.core2-64
  - allow downgrade of thunar-volman-0.8.1-r0.186.core2-64 to thunar-volman-0.8.1-r0.97.core2-64
  - allow deinstallation of packagegroup-ni-xfce-1.0-r0.96.x64

Solution 2:
  - do not ask to install a package providing opencv

admin@NI-IC-3173-xxxxxxxx:/#

 

0 Kudos
Message 1 of 3
(878 Views)

Hi PanchoPantera,

 

This issue looks like it may be a bit complicated for working on through the forums. I would recommend opening a Service Request through ni.com/support or calling into our support line at (866)-275-6964 to speak with one of our Applications Engineers, so that they can help you troubleshoot it further.

 

If you would prefer to continue using the forums, it may be helpful to share more information about specifically what you're hoping to do with these binaries. If it turns out that they are not compatible, we may be able to help you come up with an alternate path forward if we know what they do. 

 

Kathryn K.
Technical Support Engineer
National Instruments
http://ni.com/support
0 Kudos
Message 2 of 3
(825 Views)

Thank you, I will call just to check how much of a hassle it is to do this. 

 

I was trying to go this route so that I would not have to recompile all my OpenCV algorithms/functions on version 3.1. But it looks like its going to be less work to upgrade and recompile them than to continue what I´m doing x)

 

I can install opencv 3.1 on the IC through opkg, but it looks like OpenCV 3.0 has conflicts with the opencv_highgui library. 

0 Kudos
Message 3 of 3
(820 Views)