Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Scan Engine I/O forcing will not work with cRIO alias

Tried out the example Analog Forcing.vi, works fine with a url containing actual IP address but it does not

work if you use the cRIO alias.  Is this a bug?

0 Kudos
Message 1 of 4
(2,036 Views)

Hi,

 

I tried this here, and it seemed to work fine with the alias.  Can you elaborate more on the specifics of the problem? 

Regards,

Jeremy_B

Applications Engineer
National Instruments
0 Kudos
Message 2 of 4
(2,012 Views)
Here is my test case.  It works when I use the IP address in the URL but fails as indicated with the cRIO alias.
0 Kudos
Message 3 of 4
(2,008 Views)

Hi sachsm,

 

I think I may know what's going on here. Long story short, the VI you are using is probably expecting an either a name that is resolvable from a DNS server or an IP address. If the cRIO alias is not a resolvable by the network, then it won't work. You can use the old fashion ping to figure out whether the name is resolvable or not. My  guess is that your cRIO alias is not resolvable.

 

Long story:

 

I'm assuming that what you refer to as cRIO alias, is the name of the controller as it is shown in the LV Project. If that assumption is incorrect, then this may not make sense.

 

Throughout the NI software and the IP stack, controllers get identified by different names/addresses. In MAX, a controller has an IP and a MAX identification name. That identification name may or may not end up being a DNS name depending on your network settings and network infrastructure. If you configure the controller to use DHCP (Obtain an IP Address automatically), then the controller as it acquires an IP address from a DHCP server it will try to register its name as a DNS name. For most network setups I have seen it succeeds, but in some cases it could fail.

 

Now, in LabVIEW, controllers have an "IP adress / DNS name" configurable in the controller's properties page, and a Name (what I think you are referring to cRIO Alias) that to be honest I don't know where it is being used. I think shared variables use it for some things, but not sure about it.

 

In your case, I think the Forcing API expects a URL that is resolvable by the IP network, therefore the host name needs to either be a DNS name or an IP address.

 

Hope this explains the behavior you are seeing. I can see how you would like your LV Project names to do the resolution to an IP for you, but it looks as if the forcing API does not work that way (today). To make things simpler, I'd suggest always using DNS names and have the LV Project match the DNS name.

 

(I was not expecting my reply to be this long, but that's what it ended up being)

Message 4 of 4
(2,004 Views)