Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Real-time scan resources deploy problem

Solved!
Go to solution

Hi, evryone!

 

When I try to deploy c-modules I become error: "The current module settings require NI Scan Engine support on the controller."Deploy_Error.PNG

But Scan Engine has been already installed on my controller.

 

 

SWcRIO_new.PNG

 

I've already tried the following:

1. Restart controller (Does not help)

2. Reinstall Software on controller (Does not help)

3. Format Disk and Reinstall Software on controller (It worked 1 time, then it stopped helping)

4. Change module Program Mode  (Does not help)

 

 

Please, help me to solve this problem.

0 Kudos
Message 1 of 6
(281 Views)

 I found a similar solution: https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z000000kJIuSAM&l 

 

But in my case it doesn't work(((

0 Kudos
Message 2 of 6
(232 Views)

Checked out DAQmx. When I put the module in this mode and try to run Test Panels .. it gives an error -50150.

 

 

Error Test Panel.PNG

0 Kudos
Message 3 of 6
(217 Views)

I tried to run FPGA. The program compiled but refused to run, saying that Chasis was in scan mode.

 

FPGA_Error.PNG

 

With this, I configured all modules to FPGA mode.

 

Chasis_FPGA.PNG

0 Kudos
Message 4 of 6
(215 Views)

Did the cRio formatting and reinstall NI CompactRIO 20.0 (for LV2019). During installation, I did not change the selected packages, I left everything as it was by default. Updated the firmware. As a result, cRIO started working in FPGA and DAQmx modes. But in RT Scan mode, everything also does not work, because Scan Engine was not installed.

FPGA_work_set.PNG

0 Kudos
Message 5 of 6
(201 Views)
Solution
Accepted by topic author EgorKarlin

Hello @e.karlin 

The reason for this error might be various versions of LabVIEW installed on your PC. As long as when installing Scan Engine version dependent dlls are being used from C:\Program Files (x86)\National Instruments\LabVIEW 2019\resource\ScanEngineHandlers and a conflict occurs, try to repair software from NI Package Manager or reinstall it. 

Message 6 of 6
(181 Views)