Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

RT application freezes

Highlighted

My RT application at cRIO9074 freezes randomly. Sometimes it is once a day, sometimes once in three days. I use FPGA programming mode but reach some I/Os by scan interface. Strange thing is I have 2 identical system that one of them runs without a problem for 2 months since beginning. I have to switch off/on in order to restart application. I changed the hardware too but nothing has changed. My hardware equipped with interface relays and analog/analog transducers for all I/Os. The only direct connected modules are 5A rms and 300V rms input C series cards. I have DMA Fifo for reaching mentioned power measurement modules. Windows vi runs at another computer for process monitoring. It acesses process data by network published variables.

Thanks in advance...

0 Kudos
Message 1 of 5
(2,873 Views)
Highlighted

The first thing I would do is check the memory and processor resource usage of the 9074 controller when the application freezes through the Distributed System Manager tool.  If you had a memory leak or a loop with no timing taking all processor resources, your network communication process can be starved and give the appearance that your application has frozen.  If you see that either the memory or processor usage is railing, take a look through your code (or even post it here) and try to identify where the problem is coming from.

 

If you don't see any problems with the resource usage, I would use a serial cable and the console out option on the controller to see if that gives any information.

 

Let us know what you find out.

Alex Person
NI-RIO Product Support Engineer
National Instruments
0 Kudos
Message 2 of 5
(2,859 Views)
Highlighted

Hi WATCH, 

 

Do any of your c-series modules require external power supplies? A bad power supply could be causing this behavior in the FPGA code c-series modules that require power supplies.

 

Do you know the program is hanging or is it just not responding? You can check this by just flickering the user led. 

 

It will help a lot if you can isolate the real-time side of the program from the FPGA for debugging. Can you just use the scan-mode pieces of your program and see if the problem is still there? You can do this quickly with the diagram disable structure. 

 

Is there anyway to narrow down the problem area? 

 

Jesse Dennis
Engineer
INTP
0 Kudos
Message 3 of 5
(2,855 Views)
Highlighted

Dear Friends, I installed a 230/230V insulation transformer upside of the 230V/24VDC power supply because 230V was coming from UPS which can causes spikes on the wave. I can say the 24VDC power supply is top quality. And I unplugged the network cable which makes the cRIO9074 communicating with the Windows vi that runs on other computer. One more thing I did is a little modification on the fpga and rt application. I cancelled to stop FPGA when overflow or underflow happens. Now I flush the buffer instead. I was observing evertime from the windows vi that processor usage is 63-64% and memory is 52%. Now it seems stable. After some period, I will reattach the network first and then remove the transformer to understand which was the real cause. I will let all you informed.

Thanks for your help...

0 Kudos
Message 4 of 5
(2,840 Views)
Highlighted

Dear Friends,

Now the system running without any problem for 1-1,5 month. The windows vi computer network cable also been replugged.

For your information...

Best regards...

0 Kudos
Message 5 of 5
(2,747 Views)