Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

RIO server could not be found on the specified remote system




Do you have the NI-RIO driver installed on your computer? With our newer versions, sbRIOs need the NI-compactRIO driver installed.


Alex C.

National Instruments

Applications Engineering



Alex C.
Applications Engineering
National Instruments
0 Kudos
Message 11 of 21

Hi, I have "NI RIO 17.0" and "NI RIO IO Scan 17.0" drivers at NI CompactRIO 9073. I installed LabVIEW 2017 to my computer and then downloaded those drivers to the cRIO.


But still I get the error "The RIO server could not be found on the specified remote system". I formatted the cRIO and then install them again. I tried to make a new project. I can connect to the cRIO, but my project did NOT discover the chasis. When I try to deploy, I take the error ;


"Conflict Resolution : One or more items in this deployment require the NI Scan Engine and corresponding driver(s) to be installed. Go to MAT to install"


I install all of the drivers that I have on NI Software Platform Bundle to the CompactRIO. But the result is the same.


Any idea?

0 Kudos
Message 12 of 21

Hi sefaa,


Please check out this KB about the error you are seeing relating to the RIO server and reformat and reinstall software on your target if needed


Error -63044 and Blinking Status Light on RIO Target

Applications Engineering
National Instruments
0 Kudos
Message 13 of 21

Sir, I delete some of software drivers in CompactRIO, and it seems the problem has been gone. 


But now I can not deploy that has shared variable. It gives me the error " NI System Configuration: (Hex 0x80004005) Miscellaneous operation failure"


Shared_Variable deployment failed (error: -2147467259, LabVIEW)


I can not understand what happens,


Any idea??

0 Kudos
Message 14 of 21

sefaa, check that the order in which you installed the software is correct. 


Read more about this process here: LabVIEW: (Hex 0x80004005) Unspecified error. ===== NI System Configuration: (Hex 0x80004005) Miscell...


I also recommend you try upgrading the firmware of your target, if you have not done that already: Upgrading Firmware on my NI Linux Real-Time Device


All the best!

0 Kudos
Message 15 of 21

Sir, I attached MAX Tech report for both CompactRIO and My System. Also I attached the Error Images.


I want you to know that my runs if I do not create a shared variable in it. I mean I can make data acquisition at Target side.


But when I create shared variable to pass those values to the, I get this error.


OS: Windows Professional 7 SP1 64 Bit


Software: LabVIEW 2017 Professional Development System


Remote Target : NI CompactRIO 9073 (has 2017 software drivers)

0 Kudos
Message 16 of 21



Thanks for sharing those. Let me write the problem you are seeing, so we are all in the same page when offering help and you can clarify if I got something wrong:


  1. When the CompactRIO 9073 is not using Shared Variables.
  2. When you deploy Shared Variables (either because you use them in your VIs or you have created some in your project) you see the error "NI System Configuration: (Hex 0x80004005) Miscellaneous operation failure. Shared_Variable deployment failed (error: -2147467259, LabVIEW)"
  3. You have tried installing and uninstalling software from the CompactRIO and this is the current behavior with the software stack listed in the MAX reports.


Here are my outstanding questions:


  1. Besides uninstalling and installing software to the target, have you tried reformatting the target, as another post suggested?
  2. Have you tried upgrading the target's firmware, as I suggested?
  3. Have you tried using an empty project to deploy one shared variable and see if that works?


Let us know your results, and if you do the steps we are suggesting, as it's hard to help if we don't know if the steps we write are actually used.


All the best,

0 Kudos
Message 17 of 21

What I did were;


I formated the cRIO using NI MAX. I installed the required 2017 drivers to the cRIO. I tried to deploy the in the old project. I got that error. I tried to create a new shared variable in the old project. I got that error. I created a new project and tried to deploy a VI that has shared variable. Again I got this error. 


I want you to know that if I try to connect to the cRIO in a day for the first time, I get taggerrt.out missing in RT warning. If I push Apply button, it can connect and it wont give that warning again during the day.


As I Said, I simply formatted the cRIO using NI MAX. Everything has been set to default settings. The problem may be because of this.


I have no internet connection in the test pc. Can I update firmware?

0 Kudos
Message 18 of 21



You don't need to have internet access to upgrade the firmware of you controller. The Firmware for all the cRIO devices is loaded in your computer when installing the NI-RIO driver.


I find interesting that a new project with a VI that uses a Shared Variable throws the error. What happens if instead of deploying a VI, you leave the project blank and just add your target, as well as a shared variable (in the project, not in a VI), and you click Deploy on the Target (right click in the Target > Deploy All)? If you have a chance, share us a screenshot of both the project, as well as the error message. This way it can be easier for others to contribute with possible solutions.


I also see you are using a specific computer for this application. From the NI MAX report you uploaded, I see the software installed should be correct. Nevertheless, have you tried connecting to the device and deploying code from another computer? This would help discard if the problem relies on a software corruption in your development computer.


All the best,

0 Kudos
Message 19 of 21

NI support adviced it as well. What I will do is that I will connect the cRIO with another computer that has LabVIEW 2016 and install the 2016 drivers to the cRIO. If I can deploy the shared variable, there will be two options: the problem is in LabVIEW 2017 or in the PC. I will try it Monday. If you have an idea that I should try, please tell me

0 Kudos
Message 20 of 21