Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

RIO server could not be found on the specified remote system

When trying to add a cRIO9074 to an empty project, I get the following message: 


 

 The RIO server could not be found on the specified remote system. Ensure that NI-RIO software is installed and that the RIO server is running and properly configured.


 

But when installing software from MAX I cannot find anything called NI-RIO.  I am using LabVIEW 2012 + Realtime 2012.

 

As a result of this, I can't see the modules in the project window.  However, I can deploy code to the cRIO that doesn't use any input or output.

 

 

0 Kudos
Message 1 of 21
(7,659 Views)

Hi GeorgeG,

 

NI-RIO is the driver required for LabVIEW to use a RIO device like your cRIO.  You can find the most current version of the driver here: NI-RIO 12.0 for Windows

 

Once you download and install it, you should see the NI-RIO software as an option to install on your cRIO from MAX.

Jayme W.
Applications Engineer
National Instruments
0 Kudos
Message 2 of 21
(7,632 Views)
Highlighted

I am getting the same message, I am using NI sb-RIO 9611. Using LabVIEW 13, NI RIO 13, RIo Device driver (most recent), Configured the IP of the device from NI MAX, Installed the software in the remote target. 

0 Kudos
Message 3 of 21
(7,208 Views)

Hello,

 

You mentioned that you are using NI-RIO 13.0 and that you have installed the appropriate software set to your sbRIO. What is the current status of your device in MAX?

 

As the sbRIO-9611 only has 64 MB DRAM, it is possible that a “lighter” RIO software installation would free up enough memory to allow your sbRIO to run successfully. Would you consider formatting your sbRIO and then installing the NI CompactRIO 13.0 (minimal) software set?

Cameron
0 Kudos
Message 4 of 21
(7,123 Views)

I got a similar error on MyRio-1900. I installed latest NI RIO 13.1 drivers and still got the same error.

I use LV2014 with real time and FPGA module.

 

0 Kudos
Message 5 of 21
(5,224 Views)

SW on myRio wasn't updated, It's OK now.

0 Kudos
Message 6 of 21
(5,207 Views)

Hey there,

 

Everytime i´m trying to open up a new FPGA-Project for my sbRIO-9651 SOM this error occurs. I´m using LV2014 with the RT- and  FPGA-Module. This error occures even if the RIO is connected via USB. Whats the purpose of the RIO Server anyway?

 

Maybe you guys can help me with this problem.

 

Thanks

 

Nils

0 Kudos
Message 7 of 21
(4,768 Views)

Sloved. I had to update the firmware on the sbRIO.

 

 

0 Kudos
Message 8 of 21
(4,754 Views)

Hi,

 

What do you mean by wasn't updated ?

 

Regards,

0 Kudos
Message 9 of 21
(3,997 Views)

hey 

I also encountered the same problem for my sbrio-9651 som,can you help to solve it?

0 Kudos
Message 10 of 21
(2,364 Views)