Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Problem in FPGA

Highlighted

Dear All

I’m using cRIO-9074

NI-9225

NI-9239

 

LabVIEW 8.5

LabVIEW FPGA 8.5.1

cRIO 2.4.1

 

I’m Acquiring Voltage signal from Channel 0 in NI-9225 and current from Channel 0 in NI-9239 I have 2 problems.

 

The First problem is the signal acquiring fine (The voltage signal in index 0 and the current signal in index 1 in DMA) but in a few time the Value in DMA is change between to channels (The current signal in index 0 and the voltage signal in index 1 in DMA) and return back (The voltage signal in index 0 and the current signal in index 1 in DMA).

 

The second thing is The Cycle Average and RMS .VI Measure RMS for 1 Cycle; I need Measure RMS for half cycle.

How Measure half Cycle?

Please send to me the solution of this issue.

 

Regards

Spring

0 Kudos
Message 1 of 4
(2,017 Views)
Highlighted
Hi Spring,
Could you attach a screen shot of your code?  Thanks.
 
Stephen S.
National Instruments
1 Test is worth 1000 expert opinions
0 Kudos
Message 2 of 4
(2,000 Views)
Highlighted
Hi Sorooshster
H R U?
 
Thank you for send to me.
 
In the attachment 2 VIs 1-FPGA VI 2-cRIOVI
 
Regards
Spring
Download All
0 Kudos
Message 3 of 4
(1,978 Views)
Highlighted

Hi Spring,

Your code is huge and I'm missing some of the vi's needed to fully open it.  Looking at it, I'm not sure how the signals would get crossed but the only thing I can imagine is that somehow in the indexing for loop something goes wrong as you read the data into the FIFO.  You might try using two separate FIFO's, one for each channel.  Regarding the RMS measurement, you have to have at least one cycle.  If you wire anything less than 1 into the cycles input it defaults to zero and throws an error.  This makes sense, as you need at least one full cycle to accurately measure the RMS of a signal. 

Stephen S.
National Instruments
1 Test is worth 1000 expert opinions
0 Kudos
Message 4 of 4
(1,945 Views)