Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

NI cRIO-9004 not showing in MAX

Solved!
Go to solution

Hello! This is my first time to use cRIO-9004 and having trouble already beacause the controller is not showing in MAX. Is this supposed to show under remote systems? The following entries are installed in my PC, please let me know what else I'm missing.

 

LV 8.5.1

NI-RIO 2.0

 

Thanks!

______________
KowdTek
LabVIEW 2009

One Step At A Time, Maybe Two...
0 Kudos
Message 1 of 19
(3,580 Views)

Additional info:

The controller is connected to PC using cat-5 crossover cable, the link/active LED are on and the status LED blinks every 2 sec or so..

______________
KowdTek
LabVIEW 2009

One Step At A Time, Maybe Two...
0 Kudos
Message 2 of 19
(3,572 Views)

Hi Kowdtek,

 

Yes, the cRIO should show up under Remote Systems.  Your Status LED indicates that the cRIO just needs to be configured in MAX (once you can see it there).  Set the DIP switches on the cRIO to turn Safe Mode and IP Reset on, then reboot the cRIO via the reset switch.  Pending any other issues, this will make your cRIO show up in MAX with IP 0.0.0.0.  For more details on how to do this, and more information in general on how to configure the cRIO, check out the manual, which you can find here.

 

There is also a very good Knowledge Base article concerning this I highly recommend you check it out. 

 

I would also like to recommend that you update your NI-RIO driver.   The current version is 3.0.

 

Hope this helps! 

Brian A.
National Instruments
Applications Engineer
0 Kudos
Message 3 of 19
(3,543 Views)

Hi Brian,

NI-RIO Driver is updated to 3.0. I follow per instructions but still no luck. Can you confirm that the SW/driver I have is enough to make this work?

I should mentioned that I don't have the original CD that came with the unit, is ist necessary at this point?

 

Thanks!

______________
KowdTek
LabVIEW 2009

One Step At A Time, Maybe Two...
0 Kudos
Message 4 of 19
(3,540 Views)

The version of RIO you have intalled is fine. That should let you see your controller from MAX.

 

The next thing I would look at is to make sure a Firewall is not enabled (and even if they are enabled, add nimax.exe to their list of exceptions; I remember running into a problem with the windows firewall that even though it was disabled, I had to add nimax.exe to th exceptions list to see the controller).

 

Other things to try are use an ethernet switch or hub instead of the crossover cable.

0 Kudos
Message 5 of 19
(3,530 Views)

JMota wrote:

The version of RIO you have intalled is fine. That should let you see your controller from MAX.

 

The next thing I would look at is to make sure a Firewall is not enabled (and even if they are enabled, add nimax.exe to their list of exceptions; I remember running into a problem with the windows firewall that even though it was disabled, I had to add nimax.exe to th exceptions list to see the controller).

 

Other things to try are use an ethernet switch or hub instead of the crossover cable.


Hello JMota!

NIMAX.exe is added to the exeption list but still can't see the controller. I also tried to disable the firewall and the result was the same. Using ethernet switch or hub is not an option at this time (I don't have one available) but will try it. If there's any more ideas please let me know.

 

Thank you very much!

______________
KowdTek
LabVIEW 2009

One Step At A Time, Maybe Two...
0 Kudos
Message 6 of 19
(3,494 Views)

Have you tried the things mentioned at the knowledge base article that Brian A.mentioned?

 

Few other things to try:

 

+ Turn on the IP reset dip switch and reboot

+ Same thing but with the safe mode switch

+ Reboot your host computer (sometimes the TCP/IP stack gets into a bad state that requires rebooting the computer)

+ Try a different crossover cable

+ Get a null modem serial cable and see what's the output of the cRIO controller (you will have to turn on the console out dip switch on the controller)

+ Try a different computer (just install NI-RIO 3.0 on it; that will install MAX and support for cRIO controllers in MAX)

 

That's all I can think of for now. 

 

Good luck.

0 Kudos
Message 7 of 19
(3,487 Views)

First of all thank you for your time!!

My controller is now configured, I just need to update either the MAX or controller because they are not matched. Am assuming they have their own version (same verion # but one for max and one for controller)?

 

Thanks again!

Message Edited by KowdTek on 10-01-2008 12:28 PM
______________
KowdTek
LabVIEW 2009

One Step At A Time, Maybe Two...
0 Kudos
Message 8 of 19
(3,483 Views)

Now that I have configured the controller I will need to upgrade my controller's software (NI-RIO 3.0). But can't seem to find the softwares. Are these upgrades available at this time?

I already have NI-RIO 3.0 in my MAX.

 

Thanks in advance!!!

______________
KowdTek
LabVIEW 2009

One Step At A Time, Maybe Two...
0 Kudos
Message 9 of 19
(3,479 Views)

Glad to hear you were able to see your controller in MAX.

 

Can you post a screenshot of what you are seeing when trying to install software to the cRIO?

 

Do you have LV RT installed on your PC?  Did you install LV RT after installing NI-RIO?

 

JMota 

Message 10 of 19
(3,464 Views)