Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

Model Interface Toolkit CRIO 9076 ERROR -383202

Hello everybody,

 

I have some big trouble when i want run model on compactrio. Lets start from beggining. I followed many topics about model generation from simulink model a I believe I download correct software versions. In simulink everything is set up according to related topics (NIVeriStand_VxWorks.tlc,GNU toolchain,fixed step ...) so when i try to generate model everything is finished without errors and build is made successfully. Generated .out file is copied to CRIO location C:\ni-rt\system. Of course model interface toolkit and veristand is installed on crio and development computer.

 

But when i try to run the VI where model is open, following error appears:

image.png

Model library is valid, i can connect via ftp. The second statement is somehow unclear to me, maybe this is the part of the problem. I tried reinstall CRIO model interface toolkit and veristand and it didn't help. When  I look in the CRIO folder :C:/ni-rt/NIVeriStand/ there is log file:

 

 

Starting NI VeriStand Engine...
Loading /c/ni-rt/NIVeriStand/SystemDefinitionData.nivscfg

System Definition Details
-----------------------------
Name:
Version:
Description:
-----------------------------

****************************
System error encountered.
:::Details:::
Error code: -307729
Error Message: NI VeriStand: The system definition file is missing. Deploy a valid system definition file from the client computer.
=========================
NI VeriStand: Empty Configuration
****************************

System awaiting new configuration from client.
Stopping system definition...
Stop time: 00:01:48
01/01/1970

Finalizing engine timing sources...
Finalizing inline custom devices...
Finalizing FPGA devices...
Finalizing models...
Unloading system definition...
VeriStand Engine idle. Awaiting command...

 

Does anybody know what it mean and how to solve it or how to deploy system configuration for crio?

 

Second interesing thing is that if I create model as standart windows library DLL  and deploy VI on PC then everything works great.

 

software specification: Labview 2018,Veristand2018,Model interface framework 2018, Matlab2017a

Thank you 

0 Kudos
Message 1 of 2
(132 Views)

Hello,

 

I find Configuring a System Definition File document.

Have you tried to modify it?

__________________________________________
The best way to thank, is to give KUDOS
0 Kudos
Message 2 of 2
(21 Views)