Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

Memory total is missing on Desktop PC as Labview RT tagert

Hello everyone,

I'm using UNO-3072L embeded desktop from Advantech Inc. as labview RT target . The desktop passed the test with soft -"PCeavl.exe" to meet  the requirement. The target can boot to Real-time and my smaller(<15M memory using) Rt program can be deploying to the target.I find the Memory Total in the target  is just  66111K,but the PC is setting as 1G memory that i can find the message "Memory Testing:1015808K OK+32768K Share Memory" as the starting  BIOS.The message is right because Windows XP with SP2 can run perfectly.Memory Manger can check the same memory total.

The desktop PC :Celeron M 1G CPU;1x200pin SODIMM socket memory with 1GB DDR RAM.

With User memory just about 15000K I cannt do more application.

Thanks any suggestions.

0 Kudos
Message 1 of 10

Hey Taccine,


Just for clarification, the Real-Time System Manager reports ~66 Mb Total Memory and you can't run applications over that size? I'm curious whether RTSM is reporting incorrectly or if RT is only allocating that much memory.



| Michael K | Project Manager | LabVIEW R&D | National Instruments |

0 Kudos
Message 2 of 10


Thanks for reply.

Yes ,When deploying the more vi to the targer  I may run into  error message such as memory total ~66111K and available memmory usually  ~900k ,so the deploying of vi library is end .But little size vi can run conrecttly over the size.I do not know the cause.

0 Kudos
Message 3 of 10
What is the error message? Can you provide the VI that runs and the VI that does not run?

| Michael K | Project Manager | LabVIEW R&D | National Instruments |

0 Kudos
Message 4 of 10

Thanks all for your attation to my problem.I've a new PC to run my application.It seems good from now with 1GB DDR memmory.

The campatabilities  of Ni-RT with PC desktop is truely problem.

0 Kudos
Message 5 of 10



I am glad to hear you have solved the problem. We are aware of customer issues dealing with Desktop ETS PCs with LabVIEW Real-Time. The issue is manufacturers may not follow exact specifications when creating PC hardware. Instead, they create hardware to run the Windows OS successfully.


Can you expand on what you did to fix this problem?

| Michael K | Project Manager | LabVIEW R&D | National Instruments |

0 Kudos
Message 6 of 10

Hello Riconquistiamola,

Im sorry to tell you that I've no other way to fix the problem but  to substititude a new other kind of mainboard for the PC ETS .But Im  still expecting to hear the news from  NI of solving the bug soon. Thanks .

0 Kudos
Message 7 of 10

Hi Taccine,


I am glad to hear substituting a new motherboard solved your problem. Unfortunately, we do not have your exact Advantech board to confirm this issue. Without more information on your failings I cannot guarantee we will fix the problem, whatever it is. Please let me or your local Applications Engineering Department know if you are able to aide our troubleshooting in any way.



| Michael K | Project Manager | LabVIEW R&D | National Instruments |

0 Kudos
Message 8 of 10



We thought it would be worth investigating the issue and contacted Advantech for a UNO-3072L loaner.


We were able to obtain a UNO- 3072L but after spending a few days we could not get it to work. Several intermitent issues kept the system from booting correctly. We had trouble booting off several HDDs that worked fine on other systems. The random times we were able to boot the UNO with LabVIEW RT, the system rebooted promptly after attempting to configure the plug-in Ethernet adapter. We swapped PCI Ethernet adapters twice without much luck.


At this point we have not been able to narrow any of the multiple issues down to either a SW or HW bug, but I can say that we have had an easier time booting other third-party systems inthe past. We'll keep working with Advantech if necessary, but given our own experience with the UNO-3072L, we cannot recommend it as a LabVIEW Real-Time solution without explicit support and further cooperation from Advantech.




Alejandro Asenjo

LabVIEW Real-Time

National Instruments

Message 9 of 10

Alejandro Asenjo,

im great to hear ni were investigating the issue .I can tell you som message from my experience working on UNO-3072L.

1. UNO is using  realteck8139 ethernet chipset that is not meeting with Requirements for a Desktop PC as a LABVIEW-RT Real-Time. Must to swap a PCI Ethernet(After i used a card with Intel 82559 ethernet chipset, i could work) .

2.we could not successfully create  bootdisk on  the UNO PC itself  to LabVIEW RT with several kinds of HDDs or CF cards. But it can boot to LABVIEW-RT from HDDs or CF card  with bootdisk created on other PCs. It seems to work well  but the trouble as missing memmory-total.

Thanks for all.

0 Kudos
Message 10 of 10