Real-Time Measurement and Control

Showing results for 
Search instead for 
Did you mean: 

Loading and Running Bitfile NI USB-7845R OEM On Linux

I would like to use this DAQ on a Linux box however, everything works except I have no resource name. I can see the device on lsni -v . I cannot rename it using nisyscfg python script, because the type only shows up as sysconfig. So there are no clear next steps.


I've tried it on:

- RH9

- Ubuntu 22.04

- RH8


0 Kudos
Message 1 of 6

You don't say what drivers you have installed. The hardware compatibility page states you need to install the 2022Q4 Device Drivers for RHEL 9 and Ubuntu 22.04.

David C
0 Kudos
Message 2 of 6

2022 Q4, 2023 Q1, and 2020 (RHEL8), using the equivalent >> sudo dnf install ni-rseries; sudo dkms autoinstall


On each OS with a fresh OS install between each version.

0 Kudos
Message 3 of 6

Try to use the Hardware Configuration Utility for Linux, which provides similar graphical configuration functionality in Linux OS.

See Unable to Locate NI MAX on My Linux OS Based System

0 Kudos
Message 4 of 6

That would be a nice solution but for some reason, they are not supported in that utility:


Hardware Configuration Utility [Unsupported Devices] 


R Series and MXI-eRIO

These devices are not supported in Hardware Configuration Utility.


However, the device is listed as supported by the operating system. So I figure there must be a way to make them work without it.

I've also tried this as well and it indeed is listed as an unsupported unnamed device.

0 Kudos
Message 5 of 6

I do want to note that the device I'm using is listed as supported hardware for the Operating systems I was looking at:
NI Hardware and Software Operating System Compatibility - NI


So, there must be some reason for that right?

0 Kudos
Message 6 of 6