Real-Time Measurement and Control

cancel
Showing results for 
Search instead for 
Did you mean: 

LabVIEW FPGA: The compile farm server does not have any compile workers that ..

Highlighted

Hi,

 

I am unable to compile FPGA-Projects. I am getting following error:

LabVIEW FPGA:  The compile farm server does not have any compile workers that can perform this compilation.

 

Error -123002 occurred at niFpgaCompileFarm_OpenJob.vi

Possible reason(s):

NI-Farm:  No worker has registered the given capability name.


Complete call chain:
     niFpgaCompileFarm_OpenJob.vi
     niFpgaCompileWorker_OpenJob.vi
     niFpgaCompile_Worker.vi:6460001

 

My machine-setup:

Fresh-Labview install with all updates and Patches:

Labview 2013 SP1

FPGA Module 2013 SP1

Xilinx Tools 14.4

LVFPGAXilinx14_4f1Patch installed

.net Framework 4.5.1

 

My FPGA Compile Worker 2013 reports me twice:

Registered Capabilities: Xilinx 10.1 14.4 14.4 (64bit)

Registered Capabilities: Xilinx 10.1 14.4 14.4 (64bit)

 

Does anybody know, what is going on and how to fix it? I am using brandnew cRIO 9068...... I really would like to use it!!

 

King regrads,

Yogi

0 Kudos
Message 1 of 4
(5,700 Views)
Highlighted

Okay, I figured out the problem.....

 

My FPGA module was configured for compilation on remote server, which was not containing Xlinx 14.4.....

 

Setting to localhost in Options was the key.

 

Done.

 

Yogi

0 Kudos
Message 2 of 4
(5,690 Views)
Highlighted

hi

 i am also facing the same problem. where should  i have to make changes?

 

waitingh for reply

thankyou..

 

0 Kudos
Message 3 of 4
(4,376 Views)
Highlighted

Hello,

i received the same error code. in my setup i was connected to a network compile server with the ip 127.0.0.1 (localhost).

after switching to "use local compile server" it worked.

you can find these setting under tools -> options -> fpga module in the vi-editing window. i am using a german version so i hope i made a correct tranlsation of the toolbar names

regards

martin

Message 4 of 4
(4,357 Views)